Download it now!
Bug 103255 - Commandline output not sent to stdout (standard output) on Windows
Summary: Commandline output not sent to stdout (standard output) on Windows
Status: RESOLVED DUPLICATE of bug 100826
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Commandline
  Show dependency treegraph
 
Reported: 2016-10-16 10:24 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-11-21 05:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-10-16 10:24:24 UTC
Steps:
1) Open cmd.exe
2) Goto the folder containing libreoffice
3) Type `soffice --version`
4) The output appears in a GUI dialog

Version: 5.2.1.2
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
Locale: en-US (en_US); Calc: CL
Comment 1 Yousuf Philips (jay) (retired) 2016-10-16 10:24:42 UTC
This was reported here.

https://www.reddit.com/r/libreoffice/comments/57g4h1/detect_libreoffice_version_installed_from_command/
Comment 2 Regina Henschel 2016-10-16 15:12:25 UTC
The version infos are contained in the file version.ini and can be found with the keys "buildid" and "MsiProductVersion"; no need to call soffice at all.
Comment 3 Yousuf Philips (jay) (retired) 2016-10-16 19:40:16 UTC
Querying the version number was just an example of what the wrong behaviour should is happening.
Comment 4 Regina Henschel 2016-10-16 20:05:43 UTC
It seems that for --help and --version the dialog is intended for non-UNX. It is there from the beginning, see file /desktop/source/app/cmdlinehelp.cxx and its history.
Comment 5 Aron Budea 2016-10-16 20:22:46 UTC
Possibly duplicate of bug 100826?
Comment 6 Yousuf Philips (jay) (retired) 2016-10-17 03:01:28 UTC
@Regina: outputting help in the gui dialog to some degree makes sense on windows, but why would the output of the version number be something that should be outputted to a dialog. Even running `soffice --headless --version` or `soffice --invisible --version` still opens the dialog.

@Aron: Why not. :D

*** This bug has been marked as a duplicate of bug 100826 ***