Bug 103267 - FILESAVE Crash on saving approx. 230MB CSV as xlsx file
Summary: FILESAVE Crash on saving approx. 230MB CSV as xlsx file
Status: RESOLVED DUPLICATE of bug 84246
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL: http://crashreport.libreoffice.org/st...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-17 05:13 UTC by Holli Bleßmann
Modified: 2016-10-24 06:33 UTC (History)
1 user (show)

See Also:
Crash report or crash signature: ["salhelper::Thread::launch()"]
Regression By:


Attachments
Random value CSV file ~237MB (unpacked) (3.93 MB, application/x-7z-compressed)
2016-10-19 19:00 UTC, Holli Bleßmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Holli Bleßmann 2016-10-17 05:13:38 UTC
This bug was filed from the crash reporting server and is br-e60645b9-6ed9-4a0f-8b41-a22b1ef38f96.
=========================================

de:
Bei der Speicherung einer ca. 230MB großen CSV-Datei in das Excel 2013-Format kam es zu einer Fehlermeldung, dessen Wortlaut ich mir leider nicht gemerkt habe... :-(

en (google translator :-/):
When you save an approx. 230MB large CSV file in the Excel 2013 format, it occurs an error message, whose wording I unfortunately didn't notice... :-(
Comment 1 Markus Mohrhard 2016-10-17 07:35:26 UTC
Most likely you'll get an out of memory error.

std::bad_alloc + thread results in a crash so I suppose this is nothing we can fix.
Comment 2 Holli Bleßmann 2016-10-17 09:46:33 UTC
With 8GB RAM on a Win 7 Prof. 64bit system is a "out of memory" message hard to notice... btw: After the long time, the correct csv import takes >.<, M$ Excel 2013 did the job properly. But I don't like M$ Office... -.-

The csv files were deleted after convertion, so further tests are not simple to realize.
Comment 3 Tor Lillqvist 2016-10-18 07:33:45 UTC
If you have Microsoft Office, and it works, use it. We don't mind.
Comment 4 Holli Bleßmann 2016-10-18 11:18:42 UTC
<offtopic>
...but LibreOffice is my favorite office suite. Not only because the csv import is much easier than in M$ Excel. If it was my own private PC, there was neither M$ Office nor Windows installed...
</offtopic>

Btw: The linux version semms to have the same problem.
Comment 5 Holli Bleßmann 2016-10-18 11:19:36 UTC Comment hidden (obsolete)
Comment 6 Bartosz 2016-10-19 15:44:13 UTC
Please attach similar 230MB CSV file. I would like to check if such problem could be reproduced with such big file.
Comment 7 Holli Bleßmann 2016-10-19 19:00:25 UTC
Created attachment 128081 [details]
Random value CSV file ~237MB (unpacked)

Test file with random data
Comment 8 MM 2016-10-23 21:09:14 UTC
Dup of bug 84246 ?
Comment 9 Holli Bleßmann 2016-10-24 06:32:34 UTC
Yes, it seems to be a dup of the mentioned issue. But a simple search could not find it (keywords?). Thank you for your help and sorry for the dup.

Holli
Comment 10 Holli Bleßmann 2016-10-24 06:33:37 UTC

*** This bug has been marked as a duplicate of bug 84246 ***