Bug Hunting Session
Bug 103299 - Snap Objects or Object groups relative to other objects
Summary: Snap Objects or Object groups relative to other objects
Status: RESOLVED DUPLICATE of bug 100141
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval, skillUI
Depends on:
Blocks:
 
Reported: 2016-10-17 18:18 UTC by jan d
Modified: 2016-11-01 13:34 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jan d 2016-10-17 18:18:54 UTC
Description:
USER STORY: I want to align a dragged object quickly relative to other objects

SUGGESTION: Applications like InDesign or draw.io display guides and snap depended on other objects around the dragged object. So if there is an object left to the one I drag and both are roughly top aligned a guide will appear between these two and the drag will snap slightly if both are aligned. 

ALTERNATIVES: 
- The align objects functions or a numerical specification archive the same results, but are more cumbersome to use, since they demand multiple switches of interaction mode instead of blending into the dragging process. 

- the display guides around dragged object option helps visually, however, it does not provide snapping and is visually intrusive. 

Steps to Reproduce:
1. Try to align two object relative to each other (e.g. at the same distance from the left)


Actual Results:  
User has no help in doing so

Expected Results:
Context sensitive guides support the user


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 Heiko Tietze 2016-11-01 13:04:48 UTC
This request has been asked for in bug 100141 regarding visual alignment and spacing guides (would suggest to hi-jack this ticket in case the snapping aspect is not covered well enough).

Remark: There are plenty of alignment tools that can be used, but you are likely aware of them.

*** This bug has been marked as a duplicate of bug 100141 ***
Comment 2 jan d 2016-11-01 13:34:08 UTC
Yes, that seems to be the same issue, the lined video in bug 100141 shows what I mean.