Download it now!
Bug 103368 - FORMATTING: Conditional Formatting dependent on neighbor cell breaks upon deleting line
Summary: FORMATTING: Conditional Formatting dependent on neighbor cell breaks upon del...
Status: RESOLVED DUPLICATE of bug 104026
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2016-10-20 21:31 UTC by Ralf
Modified: 2017-03-16 21:47 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example file (18.66 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-10-20 21:36 UTC, Ralf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf 2016-10-20 21:31:48 UTC
Description:
Table with conditional formatting used in at least one column:
When deleting an entire line the next line's conditional formatting will be broken when it uses a reference to a neighbor cell.

Steps to Reproduce:
1. Open example file CondFormatTest.ods (attached)
2. Select any cell in line 2 (e.g. B2)
3. Check the cell's conditional formatting
==> It's dependent on the formula IF(I2="Mediathek") [reference to neighbor cell]
4. Select menu Table => Delete Line
==> Line 2 disappears and lines 3, 4, and 5 are moved one up.
5. Check conditional formatting of cell H2
==> It's expected to show the formula IF(I2="Mediathek") [reference to neighbor cell]
==> But it rather shows IF(I#REF!="Mediathek") [reference is broken]

Actual Results:  
After moving the line 3 one up the reference to formerly I3 in conditional formatting breaks and is replaced with I#REF

Expected Results:
After moving the line 3 one up the reference to formerly I3 in conditional formatting is expected to be replaced with I2


Reproducible: Always

User Profile Reset: No

Additional Info:
I don't think it's specific to version 5.2.2.2 because I observed that behavior with some previous versions, too (at least since major version 5).


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 Ralf 2016-10-20 21:34:17 UTC
Sorry, little error in reproduction steps:
Step 2. should read:
2. Select cell H2
Comment 2 Ralf 2016-10-20 21:36:37 UTC
Created attachment 128109 [details]
Example file
Comment 3 m.a.riosv 2016-10-20 21:44:37 UTC
*** Bug 103367 has been marked as a duplicate of this bug. ***
Comment 4 m.a.riosv 2016-10-20 22:02:38 UTC
Repro

Version: 5.2.3.1 (x64)
Build ID: 01ec8f357e651ca9656837b783cf7e6a32ee4d92
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; 
Locale: es-ES (es_ES); Calc: CL

Version: 5.3.0.0.alpha0+
Build ID: c2b48a763df113e63e6a27ee05b9a6834e4e49a4
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-10-20_06:56:44
Locale: es-ES (es_ES); Calc: CL
Comment 5 Markus Mohrhard 2017-03-16 21:47:56 UTC

*** This bug has been marked as a duplicate of bug 104026 ***