Bug 103379 - Paste data in Firebird DB table fails
Summary: Paste data in Firebird DB table fails
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Database-Firebird
  Show dependency treegraph
 
Reported: 2016-10-21 09:26 UTC by Gerhard Schaber
Modified: 2016-12-15 11:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Source file (3.70 KB, application/vnd.sun.xml.base)
2016-10-21 09:26 UTC, Gerhard Schaber
Details
Destination file (3.05 KB, application/vnd.sun.xml.base)
2016-10-21 09:26 UTC, Gerhard Schaber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerhard Schaber 2016-10-21 09:26:02 UTC
Created attachment 128116 [details]
Source file

When I copy a table from an HSQLDB file to a table with the same definition in a Firebird DB file, it fails. The same when I try to past selection from Calc into that DB table.

Right-click the table in the one file, select Copy, right-click the table in the Firebird DB file, and select Paste. Chose Append Data. 

SQL Status: HY004
Incorrect type for setString

If you manage to paste multiple lines from Calc, it actually stores the first line and messes up the ID (first row, primary index). See the attached files.
Comment 1 Gerhard Schaber 2016-10-21 09:26:52 UTC
Created attachment 128117 [details]
Destination file
Comment 2 Gerhard Schaber 2016-10-21 09:29:19 UTC
Expected behavior is that it would paste all data to the destination file correctly. All data must be the same on the destination afterwards (ID, date, text).
Comment 3 robert 2016-10-21 18:34:28 UTC
Could confirm the buggy behavior. It's like https://bugs.documentfoundation.org/show_bug.cgi?id=70425 , but there seems to be also a problem with dates. "SetString" must be wrong for Integer and for Date.

Test-Version: 5.3.0.0.alpha0+
Build ID: e7324c5705eaa38a2c9aa0636f01a73f033ba4d6
CPU Threads: 4; OS Version: Linux 4.1; UI Render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-10-20_06:12:58
Locale: de-DE (de_DE.UTF-8); Calc: group