Bug 103384 - Closing a database with internal Firebird3 <Ctrl>+<W> and confirming to save the ODB leads to a hang
Summary: Closing a database with internal Firebird3 <Ctrl>+<W> and confirming to save ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Database-Firebird
  Show dependency treegraph
 
Reported: 2016-10-21 12:30 UTC by thackert
Modified: 2016-11-25 13:36 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
log from "soffice --backtrace" (22.99 KB, text/x-log)
2016-10-21 12:30 UTC, thackert
Details
bzip'd "soffice --strace" log (372.39 KB, application/x-bzip)
2016-10-21 12:32 UTC, thackert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description thackert 2016-10-21 12:30:56 UTC
Created attachment 128120 [details]
log from "soffice --backtrace"

Hello @ll,
while trying to reproduce #103373, I stumble upon the following:
1. Start LO
2. Use "ID" as field name and set "AutoValue" to "Yes"
3. Use "Name" as field name and set it to "Text [VARCHAR]"
4. Save the Table design and close it
5. Open it in Base via doubleclick
6. Enter some Name in the "Name" column
7. Press <Crtl>+<S> to save the table
8. Close it
9. Press <Crtl>+<W> in Base

You will the save dialog in Base

10. Press Enter

Now LO just hangs ... :( If I use <Ctrl>+<S> to save the document in step 10, I can close it afterwards without a problem ... :( Will attach a gdb.log as well as a strace.log.bz2. to this bug.

OS: Debian Testing AMD64
LO: Version: 5.3.0.0.alpha1
Build ID: f4ca1573fcf445164c068c1046ab5d084e1b005f
CPU Threads: 4; OS Version: Linux 4.5; UI Render: default; VCL: gtk2; 
Locale: de-DE (de_DE.UTF-8); Calc: group
(parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux)
Java™: java version "1.8.0_122-ea"                                                                                                                                                                                                                                                     
Java(TM) SE Runtime Environment (build 1.8.0_122-ea-b02)                                                                                                                                                                                                                        
Java HotSpot(TM) 64-Bit Server VM (build 25.122-b02, mixed mode)

Sorry for the inconvience
Thomas.
Comment 1 thackert 2016-10-21 12:32:04 UTC
Created attachment 128121 [details]
bzip'd "soffice --strace" log
Comment 2 thackert 2016-10-21 12:56:27 UTC
@Lionel, Tamas: Alex recommended to put you to the CC of this bug. If this is wrong, feel free to remove your names :)
Have a nice day
Thomas.
Comment 3 Joel Madero 2016-10-23 21:38:55 UTC
Version: 5.2.2.2
Build ID: 1:5.2.2-0ubuntu1~xenial0
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group

Can't repro. You sure you're running 5.2.0.0 and not 5.3.0.0?
Comment 4 thackert 2016-10-24 06:12:06 UTC
Hello Joel, *,
(In reply to Joel Madero from comment #3)
> Version: 5.2.2.2
> Build ID: 1:5.2.2-0ubuntu1~xenial0
> CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; 
> Locale: en-US (en_US.UTF-8); Calc: group
> 
> Can't repro. You sure you're running 5.2.0.0 and not 5.3.0.0?

sorry, you are right. It seems, that I was blind / too absent-minded when choosing the version from BZ's list of available versions ... :( But I mentioned in my bug report that I was using 5.3.0.alpha1 ... ;)
Sorry for the inconvenience and have a nice day
Thomas.
Comment 5 Alex Thurgood 2016-10-25 08:21:16 UTC
Confirming on Ubuntu 16.04 with my own latest (23/10/2016) LOdev530 master build

The main UI window becomes completely unresponsive, no elements or objects are clickable via the mouse or actionable via the keyboard. In the end, the OS kicks in and says the app is not responding, and would I like to kill it.
Comment 6 Julien Nabet 2016-11-12 09:06:25 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this.
Perhaps I missed something.

Could someone retest with an even more recent daily build?
Comment 7 Julien Nabet 2016-11-12 09:09:20 UTC
To be precise, when I press Enter, I got LO startcenter.

BTW, I used "Integer" to have "Autovalue" option.
Comment 8 thackert 2016-11-12 11:07:20 UTC
Hello Julien, *,
(In reply to Julien Nabet from comment #7)
> To be precise, when I press Enter, I got LO startcenter.
> 
> BTW, I used "Integer" to have "Autovalue" option.

me too. But if I retest it with

OS: Debian Testing AMD64
LO: Version: 5.3.0.0.alpha1+
Build-ID: 0af30952982767543cddd0b1ce643cb8d5c253a2
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: Standard; VCL: gtk2; Layout Engine: new; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-11-11_23:43:27
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group
(parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux) it still hangs. Clicking on the X button to close it or <Ctrl>+<W> (or <Q>) several times after a while leads to an XFCE warning dialog with the text "This window might be busy and is not responding. Do you want to terminate the application?" ... :(
Have a nice day
Thomas.
Comment 9 thackert 2016-11-25 13:06:56 UTC
Hello @,
it seems to be fixed with

OS: Debian Testing AMD64
LO: Version: 5.3.0.0.beta1
Build-ID: 690f553ecb3efd19143acbf01f3af4e289e94536
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: Standard; VCL: gtk2; Layout-Engine: neu; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group
(parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux)

so it would be kind if you could test this with 5.3.0.0.beta1 again to see, if it is also fixed for you. And it would be nice if you could close this bug then ... ;)
TIA
Thomas.
Comment 10 Julien Nabet 2016-11-25 13:36:34 UTC
thackert: Let's put this one to WFM since you're the reporter.

Alex: if you can reproduce this, don't hesitate to reopen this tracker.