Download it now!
Bug 103412 - Base report builder: "font color" and "background color" buttons in conditional formatting are broken
Summary: Base report builder: "font color" and "background color" buttons in condition...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.2.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Conditional-Formatting Database-Reports-Builder
  Show dependency treegraph
 
Reported: 2016-10-22 15:10 UTC by froilens
Modified: 2017-07-30 17:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
broken buttons (923.14 KB, video/mp4)
2016-10-22 15:10 UTC, froilens
Details
Database with only a report and an empty textbox. (6.18 KB, application/vnd.oasis.opendocument.database)
2016-10-23 07:27 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description froilens 2016-10-22 15:10:52 UTC
Created attachment 128160 [details]
broken buttons
Comment 1 Robert Großkopf 2016-10-22 19:35:03 UTC
I could confirm it is very difficult to get the menu of "font color" and "background color" in conditional formatting.

To reproduce:
Open a database-file.
Goto reports and create a report without assistant.
Create a textfield without connection to any table.
Goto Format > Conditional Formatting
Try to choose "font color" or "background color" from a palette.
Most of the trials won't work. I had luck when pointing to the upper right corner of the button.

My system: OpenSUSE 42.1 64bit rpm Linux, LO 5.2.2.2
Comment 2 Robert Großkopf 2016-10-22 19:49:30 UTC
Have tested a little bit more.
Works right with LO 5.0.5.2
Fails since LO 5.1.*
So a regression.

The GUI changed with the same version. Could be it is a special LO KDE-bug. I will see this later.
Comment 3 Robert Großkopf 2016-10-23 07:20:33 UTC
Have tested this with
Version: 5.3.0.0.alpha1
Build ID: f4ca1573fcf445164c068c1046ab5d084e1b005f
CPU Threads: 4; OS Version: Linux 4.1; UI Render: default; VCL: kde4; 
Locale: de-DE (de_DE.UTF-8); Calc: group

First I doesn't install the KDE-integration package. Then I opened a report, marked a textfield and satated 
Format > Conditional Formatting
I could choose "Font Color" and "Background Color" without any problem.

Then I installed KDE-integration. The icon-style changed to Breeze.
With this installation I couldn't choose "Font Color" and "Background Color".

This bug seems to be a special KDE-integration bug and is independent of the version of LO.
Comment 4 Robert Großkopf 2016-10-23 07:27:31 UTC
Created attachment 128185 [details]
Database with only a report and an empty textbox.

Open the attached database.
Open the report for editing.
Mark the textbox.
Open Format > Condition Formatting.
Try to choose Background-Color or Font-Color.
Won't work, if KDE-integration is installed under
OpenSUSE 42.1 64bit rpm Linux KDE Plasma Version 5.5.5, specially tested here with the first 5.3.0.0.alpha1
Build ID: f4ca1573fcf445164c068c1046ab5d084e1b005f

Works with this version, if KDE-integration isn't installed.
Comment 5 Julien Nabet 2017-07-24 18:59:38 UTC
On pc Debian x86-64 with kde4 rendering on master sources updated today or with LO Debian package 5.3.4, I don't reproduce this.

Robert/Matteo: could you give it a try with a recent LO version?
Comment 6 froilens 2017-07-30 15:23:12 UTC
Julien: I'm sorry, but I don't use Ubuntu anymore, so I won't be able to test it.
Comment 7 Robert Großkopf 2017-07-30 17:41:31 UTC
Could confirm it is working now with
Version: 5.3.5.1
Build-ID: 020db1aa8142e57290f8a21e4df31185392d0e38
CPU-Threads: 4; BS-Version: Linux 4.4; UI-Render: Standard; VCL: kde4; Layout-Engine: neu; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

(OpenSUSE 42.2 64bit rpm Linux)

Set this one to RESOLVED and WORKSFORME.