Bug Hunting Session
Bug 103508 - Underline, Strikethrough, and Overline sizes and position are permanently fixed and cannot be adjusted
Summary: Underline, Strikethrough, and Overline sizes and position are permanently fix...
Status: RESOLVED DUPLICATE of bug 68573
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-25 23:51 UTC by minutemeter
Modified: 2017-01-05 00:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description minutemeter 2016-10-25 23:51:18 UTC
Description:
The thickness and positions of Underline, Strikethrough and Overline are arbitrarily set according to the typeface font being used and cannot be adjusted by you, the end user of LibreOffice.

Steps to Reproduce:
1. Type any text you are familiar with, e.g. "The quick brown fox jumps over the lazy dog," etc., and use the Edit > Copy/Paste to repeat the text multiple times, all while making everything is the same size (e.g. 14-point size).
2. Select each line individually, then assign a different typeface font to each line, so that every line is of a different font.
3. Next, select "All" (Ctrl-A or Edit--> Select All) then select Format--> Character. In the dialog that shows up, select the Font Effects tab, then select the various Overline, Strikethrough and Underline features (especially the Wave and Double Wave features of Overline and Underline).

Actual Results:  
The thickness and position of Overline, Strikethrough and Underline is arbitrary according to the parameters set forth by the typeface font used, and the Wave sizes of the Wave and Double Wave features are big with one font and small with another font.

Expected Results:
Overline, Strikethrough and Underline size and position should be uniform across all fonts being used. This usually cannot be done automatically, so end users of LibreOffice need to have a new option to adjust these parameters manually.


Reproducible: Always

User Profile Reset: No

Additional Info:
Ideally, in the Format-->Character command, LibreOffice users should have a new option to manually adjust the size, thickness and exact position of each Overline, Strikethrough and Underline on their own terms rather than those set forth by the individual fonts' designers.

For high school & college students, job applicants and top management of any company, professional reporters, etc, the ability to adjust underline, strikethrough and overline thickness and position manually can be a real necessity for anyone to mantifest professional penmanship. Excellent grammar is not enough!


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 David Tardon 2016-10-26 08:38:43 UTC
(In reply to minutemeter from comment #0)
> For high school & college students, job applicants and top management of any
> company, professional reporters, etc, the ability to adjust underline,
> strikethrough and overline thickness and position manually can be a real
> necessity for anyone to mantifest professional penmanship. Excellent grammar
> is not enough!

IMHO the best way to manifest professional penmanship is to not use underline, overline and strikethrough at all.
Comment 2 V Stuart Foote 2017-01-05 00:54:53 UTC

*** This bug has been marked as a duplicate of bug 68573 ***