Bug Hunting Session
Bug 103574 - Imagemap dialog lacks on confirmation button
Summary: Imagemap dialog lacks on confirmation button
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: abhilash300singh
URL:
Whiteboard: target:5.4.0
Keywords: easyHack, skillUI, topicUI
Depends on:
Blocks: Dialog
  Show dependency treegraph
 
Reported: 2016-10-29 12:53 UTC by Heiko Tietze
Modified: 2017-02-14 08:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2016-10-29 12:53:21 UTC
When running the dialog with a theme that has no window decoration it is not possible to close it because the "upper right x" is hidden. 

Every dialog needs means such as confirmation buttons Ok/Cancel to close. As an easy solution the toolbar of this dialog could have another button with the action TBI_CLOSE. The ui file is located at svx/uiconfig/ui/imapdialog.ui.
Comment 1 V Stuart Foote 2016-10-29 15:42:14 UTC
Incorrect.

From the General Keyboard Shortcut help:

Esc::
Terminates the action or dialog. If in LibreOfficeDev Help: goes up one level.

So we already provide the <Esc> shortcut, does that not function? IMO this UI behavior is similar to what we've now done for the <Alt> key to toggle mnemonic accelerators visible.

Why in general clutter each dialog with additional buttons--just to accommodate those choosing "a theme that has no window decoration"?
Comment 2 Heiko Tietze 2016-10-30 08:50:02 UTC
The issue was reported by a user and she had no clue how to close the dialog (not sure if escape works on her system).

Additionally, we aim for consistency and familiar layout is a goal, and accessibility - escape is typically connected to the cancel button, setting a modal result without an UI control might be hackish.
Comment 3 Katarina Behrens (CIB) 2016-10-31 09:29:20 UTC
I initially had no idea how to close the dialog either (in the absence of upper right corner [x])

Most of our dialogs, even modeless ones, usually have some Cancel/Close/Dismiss button, so this should be made consistent. That said, I'd not do that through toolbars, but add some regular button to the bottom of the dialog ... but different people can have different opinions on this.

Thus, confirmed. Inherited from OOo since it's always been like that
Comment 4 V Stuart Foote 2016-10-31 15:40:27 UTC
Well it raises an interesting question--is the project responsible for providing GUI elements that an OS and DE removes? Guess we do it for OS X so why not each Desktop flavor for Linux?

Otherwise adding the _additional_ button widget for close/cancel to each dialog is intrusive, since the frame decoration already has the button and when ommitted by the DE the <Esc> short-cut performs the function anyhow.

Not a fan.
Comment 5 Commit Notification 2017-01-17 06:56:32 UTC
Abhilash Singh committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bc8eb82877f544d8cf80e6f3ea02a9993e058491

tdf#103574 Imagemap dialog lacks on confirmation button

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 jani 2017-01-18 06:29:29 UTC
Assume this is resolved
Comment 7 Heiko Tietze 2017-01-18 08:09:12 UTC
(In reply to jan iversen from comment #6)
> Assume this is resolved

Yes, it is. Still one the ugliest dialog, and the close button somewhere in the toolbar is also not the best UX. But the functionality is there now. Thanks Abhilash!