Bug Hunting Session
Bug 103617 - Add custom shapes line and arrow that can becoming an arc
Summary: Add custom shapes line and arrow that can becoming an arc
Status: RESOLVED DUPLICATE of bug 66587
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2016-11-01 11:29 UTC by sportegioco
Modified: 2017-01-23 14:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of custom shapes line and arrow (19.76 KB, application/vnd.oasis.opendocument.graphics)
2016-11-01 11:29 UTC, sportegioco
Details
Two shape examples (9.38 KB, application/vnd.oasis.opendocument.graphics)
2017-01-19 22:37 UTC, Regina Henschel
Details
CustomShapesLineAndArrow-02.odg (25.76 KB, application/vnd.oasis.opendocument.graphics)
2017-01-20 00:49 UTC, sportegioco
Details
handles added for start and end point (9.42 KB, application/vnd.oasis.opendocument.graphics)
2017-01-20 12:59 UTC, Regina Henschel
Details
BezierInCustomShape_with_start_end_handles_wavyLine (15.78 KB, application/vnd.oasis.opendocument.graphics)
2017-01-20 15:18 UTC, sportegioco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sportegioco 2016-11-01 11:29:44 UTC
Created attachment 128401 [details]
Example of custom shapes line and arrow

Add custom shapes line and arrow that can becoming an arc
Comment 1 Heiko Tietze 2016-11-01 12:17:55 UTC
You can manipulate the sampling points. Press F8 (or use the context/main menu/toolbar) and look for "edit points". What are you missing exactly?
Comment 2 sportegioco 2016-11-01 14:32:06 UTC
I added a file that explains what I need. F8 solves the problem for an expert, but I would to have a custom shapes that solves the problem in a much more simple. Thank you
Comment 3 Regina Henschel 2016-11-01 16:06:28 UTC
In case do you mean "custom shape" in as technical term, then yes, it is possible in principle. You can define own shapes, but there exists no UI to do it. You need to write it into the file text yourself. You need to know the needed mathematic, to describe how the handle should modify the outline of the shape. If you want to do it, come to the mailing list or forum to get same hints and links.

The description of the desired shape is too vague here, to make it possible, that someone else can define it for you.
Comment 4 sportegioco 2016-11-01 17:27:08 UTC
Dear  Regina Henschel and  Heiko Tietze,

custom shape that I mean are those which have the ability to be adjusted by a simple yellow handle. I'm not a math expert, just wonder if someone can help me define a modifiable form, as I have defined in the attached file.
Thank you
Comment 5 Regina Henschel 2017-01-19 22:37:10 UTC
Created attachment 130567 [details]
Two shape examples

Please look, whether this kind of shapes meets your requirements. If yes, you can copy and paste them to your documents and add them to the Gallery.
Comment 6 sportegioco 2017-01-20 00:49:50 UTC
Created attachment 130570 [details]
CustomShapesLineAndArrow-02.odg
Comment 7 sportegioco 2017-01-20 00:50:52 UTC
Dear Regina Henschel, 

I am very excited about the work you have done. A real good job.
I apologize for my English, I got help from google translator and surely you see.

I ask you if it is possible only get the arrow, without the rectangle around. Like a connector, but without connecting anything.
I need these arrows for sporting diagrams, arrows represent the trajectory of the ball or the movement of the players.

Also I need an arrow with the wavy line style that I can move lengthen and shorten as a normal arrow with the style of a straight line, like the one I reported in the attached file.

I think you're a very nice person. I live in Italy, in Tuscany and I would be very happy to host you at my house if you like.

If you did not understand well, I can attach a video explaining the arrow I need. Thanks thanks thanks
Comment 8 Regina Henschel 2017-01-20 12:59:58 UTC
Created attachment 130574 [details]
handles added for start and end point

(In reply to sportegioco from comment #7)

> I ask you if it is possible only get the arrow, without the rectangle
> around. Like a connector, but without connecting anything.

No, that is not possible for custom shapes. A custom shape always works on a kind of rectangle as basis. It has "svg:x" "svg:y" "svg:width" and "svg:height", which defines position and size of a rectangular area. This defines those edges, where you see the blueish handles, if you select a custom shape. All lines and areas of a custom shape are defined relative to this rectangular area.

You can get a handle for the start and/or end of the line in the custom shape, but the rectangular area remains. Those shapes are in the attached document. Don't forget, that you can stretch, rotate and shear the shapes to fit them to your drawing.

If you need pure lines you better use the curve and adjust the outline in point edit mode. You do so well with the curves, that I wonder why you need the special yellow custom shape handles at all.

> Also I need an arrow with the wavy line style that I can move lengthen and
> shorten as a normal arrow with the style of a straight line, like the one I
> reported in the attached file.

A wavy line as line style is not implemented. If you look at your example in point edit mode, you see a lot of points. In a custom shape each of this points need to be defined in its mathematical coordinates and only a fixed number of internal points are possible. There exists no possibility to adapt the number of "waves" to the length of the line, so that it looks similar in different lengths. But I agree, to have a wavy line style would be really good, for all kind of lines. The request is already in bug 66587.

> 
> If you did not understand well, I can attach a video explaining the arrow I
> need.

I'm not the person to implement a wavy line style or other kind of lines. Put for a developer it is important to be very clear about the requested feature. Therefore such video would be good.
Comment 9 sportegioco 2017-01-20 15:18:04 UTC
Created attachment 130580 [details]
BezierInCustomShape_with_start_end_handles_wavyLine

Dear Regina Henschel,
You have done a really excellent job. I thank you very much. The wavy line is not possible and I am very sorry, but these two lines are for me a big step forward. Thanks, Thanks, Thanks again.

...A wavy line as line style is not implemented. If you look at your example in point edit mode, you see a lot of points...      it is true the line that I posted as an example has many points but for me would be fine a line with fewer points like the one that attacked files in place ...A point every turn. you can create it?


In the attached file you can find a straight line with handles to stretch and shrink.

...and the real difficulty the wavy line which becomes an arc with a handle or two handles? do you think it's possible?

Thanks you in advance.
Comment 10 Heiko Tietze 2017-01-23 14:14:21 UTC
So 50% are solved, and Regina earned a vacation. And the rest is a duplicate of bug 66587. What you illustrate in the examples is unfortunately not possible today.

*** This bug has been marked as a duplicate of bug 66587 ***