Bug 103633 - segfault when Form Design Mode is enabled
Summary: segfault when Form Design Mode is enabled
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All Linux (All)
: medium critical
Assignee: David Tardon
URL:
Whiteboard: target:5.3.0
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2016-11-02 00:23 UTC by Jim Avera
Modified: 2016-11-03 08:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
.ods spreadsheet which provokes the crash (290.70 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-11-02 00:25 UTC, Jim Avera
Details
gdb backtrace (22.92 KB, text/plain)
2016-11-02 00:26 UTC, Jim Avera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2016-11-02 00:23:48 UTC
Description:
When the attached spreadsheet is loaded, entering Form Design Mode immediately crashes Libre Office.  Running with --backtrace shows a segfault in
accessibility::AccessibleControlShape::modeChanged (full trace attached).   

The crash does not happen with other, less-complicated spreadsheets.

The crash happens even with macros DISABLED.  So it is some static state in this spreadsheet which tickles the bug.


Steps to Reproduce:
1.  Load attached test spreadsheet
2.  DISABLE macros when prompted
3.  View->Toolbars->Form Design
4. Click the left-most icon on the Form Design toolbar (enters Design Mode)

Actual Results:  
Immediate crash

Expected Results:
No crash


Reproducible: Always

User Profile Reset: No

Additional Info:
Note: This same spreadsheet provokes a seemingly-unrelated segfault, reported in bug 103632.   That other bug happens when a macro sorts the spreadsheet.  But maybe there is something about this .ods file which makes LO randomly corrupt memory or in some other way cause different segfaults to happen later.


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 Jim Avera 2016-11-02 00:25:16 UTC
Created attachment 128418 [details]
.ods spreadsheet which provokes the crash
Comment 2 Jim Avera 2016-11-02 00:26:04 UTC
Created attachment 128419 [details]
gdb backtrace
Comment 3 Xisco Faulí 2016-11-02 08:06:23 UTC
Confirmed in 

Version: 5.3.0.0.alpha1+
Build ID: 64d3bd38c9242c1cc114f6e68bf13475ef679b73
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; VCL: gtk2; Layout Engine: old; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 4 Xisco Faulí 2016-11-02 08:10:16 UTC
I can't reproduce it in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)
Comment 5 Xisco Faulí 2016-11-02 08:23:19 UTC
Regression introduced by

author	Noel Grandin <noel@peralex.com>	2016-05-31 13:07:58 (GMT)
committer	Noel Grandin <noelgrandin@gmail.com>	2016-06-02 06:32:07 (GMT)
commit	8e8a88ec1ad02c153ae3c7653edc81716dc91b7a (patch)
tree	6762b644bdfbadeaacea13c05abb23b8c95e1efe
parent	b6056eabfa8583d687165e3f9656cd322230829c (diff)

loplugin:unusedfields

Adding Cc: to Noel Grandin
Comment 6 Commit Notification 2016-11-03 08:56:50 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4a83464f718ba8534a738178670077d5636ad051

tdf#103633 avoid segfault in a11y

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.