Download it now!
Bug 103741 - Wrong rendering of number on vertical ruler in Writer
Summary: Wrong rendering of number on vertical ruler in Writer
Status: RESOLVED DUPLICATE of bug 100986
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2016-11-06 20:50 UTC by Roman Kuznetsov
Modified: 2017-03-03 03:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
OpenGL is enabled (29.81 KB, image/png)
2016-11-06 20:51 UTC, Roman Kuznetsov
Details
OpenGL is disabled (30.62 KB, image/png)
2016-11-06 20:52 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2016-11-06 20:50:21 UTC
Description:
If new text layout engine (HarfBuzz) is activate, then vertical ruler in Writer:

1. OpenGL is enable -> number on ruler not displayed
2. OpenGL is disable -> number on ruler wrong rendered

see attach also

Steps to Reproduce:
1. Open Writer
2. Menu View-Rulers-Vertical ruler -> enable
3. See to vertical ruler (or my screenshot)

Actual Results:  
wrong rendering of number on vertical ruler

Expected Results:
normal rendering of number on vertical ruler


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.3.0.0.alpha1+
Build ID: 4ea62fe8a1194bca3bee5048832456c3559dcb8e
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-05_23:04:01
Locale: ru-RU (ru_RU); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Roman Kuznetsov 2016-11-06 20:51:25 UTC
Created attachment 128533 [details]
OpenGL is enabled
Comment 2 Roman Kuznetsov 2016-11-06 20:52:06 UTC
Created attachment 128534 [details]
OpenGL is disabled
Comment 3 Khaled Hosny 2016-11-06 21:02:15 UTC
Most likely a duplicate of bug 100986.
Comment 4 Roman Kuznetsov 2016-11-06 21:09:46 UTC
(In reply to Khaled Hosny from comment #3)
> Most likely a duplicate of bug 100986.

that bug is for text in document. this bug for GUI. Or this is not important?
Comment 5 Khaled Hosny 2016-11-06 21:13:25 UTC
(In reply to kompilainenn from comment #4)
> (In reply to Khaled Hosny from comment #3)
> > Most likely a duplicate of bug 100986.
> 
> that bug is for text in document. this bug for GUI. Or this is not important?

It shouldn’t matter, all text is eventually rendered by the same code in VCL.
Comment 6 V Stuart Foote 2016-11-06 22:59:12 UTC
Confirming on Windows 10 Pro 64-bit (1607) en-US with
Version: 5.3.0.0.alpha1+
Build ID: 32bdc5097013e7efd9c85e1b8df697880e66e925
CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-04_23:30:30
Locale: en-US (en_US); Calc: CL

labeling of ruler is not rotated with GDI+ and DirectWrite with HarfBuzz, and with OpenGL rendering and HarfBuzz is not displayed at all.
Comment 7 Khaled Hosny 2016-11-08 15:09:01 UTC

*** This bug has been marked as a duplicate of bug 100986 ***