Bug Hunting Session
Bug 103751 - RTL outline numbering not working as expected...
Summary: RTL outline numbering not working as expected...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:rtf
Depends on:
Blocks: RTL-CTL Chapter-Numbering
  Show dependency treegraph
 
Reported: 2016-11-07 07:11 UTC by Nima Az
Modified: 2019-01-26 12:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
examples of what happens of what must happen (14.78 KB, application/vnd.oasis.opendocument.text)
2016-11-17 07:11 UTC, Nima Az
Details
Description about problem (58.41 KB, image/png)
2016-11-20 14:20 UTC, You Have End
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nima Az 2016-11-07 07:11:44 UTC
Description:
I need to number chapters and subheadings in chapters in my thesis in a right-to-left language (Persian).  The outline numbering works as expected in LTR but when I switch the text direction, the order of heading numbers will not change.  For example, 1.2.3 in LTR would refer to subheading 3 of subheading 2 of chapter one.  In RTL I expect it to show on the right side of the page in the reversed order, ie., ۳.۲.۱.

Steps to Reproduce:
1. define outline numberings for heading 1, heading 2, etc.
2. modify heading styles text direction to RTL
3. apply the styles to the heading titles

Actual Results:  
outline numberings appeared in the wrong direction.

Expected Results:
in RTL language chapter number should appear on the right side, then outline number for heading 2, the heading 3, etc.


Reproducible: Always

User Profile Reset: Yes, many times.

Additional Info:
Just that this is very urgent.  If this cannot be resolved soon, I may have to switch to MS Office which I have resisted many years.  Or I will have to enter outline numberings manually.

I have searched for this problem.  Some people had mentioned the same issue in other places since maybe 2012 and some had suggested that this cannot be solved and a bug report/feature request must be filed.  I was unable to solve it too and did not find a bug filed for it, and hence the report.


User-Agent: Mozilla/5.0 (Windows NT 10.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2486.0 Safari/537.36 Edge/13.10586
Comment 1 You Have End 2016-11-15 18:37:11 UTC
شما می توانید یک فایل پیوستی را همین جا بگذارید تا من مشکل را گزارش کنم
با تشکر
Comment 2 You Have End 2016-11-15 18:38:55 UTC
یا اگر نیاز به تغییر در جایی بود به فارسی توضیح دهید تا آن را به تیم لایبر آفیس اطلاع بدم
Comment 3 Nima Az 2016-11-17 07:11:13 UTC
Created attachment 128797 [details]
examples of what happens of what must happen
Comment 4 Nima Az 2016-11-17 07:11:50 UTC
سلام
لطفا فایل پیوستی را ملاحظه بفرمایید.  اینجا در واقع دو ایراد وجود دارد. یکی را قبلا توضیح دادم و دیگری را در این فایل اضافه کردم. داخل فایل مثال زده‌ام.

خیلی متشکرم.
Comment 5 Nima Az 2016-11-17 07:29:43 UTC
در مورد علامت اعشار امیدوارم مساله در مورد شماره‌ی فصل‌ها و زیر فصل‌ها و ترکیب‌هایی مانند «(... ۲۱۳). بببب» که توضیح دادم حل شود و تاثیری روی رفتار لیبره آفیس با اعداد اعشار خالص مثل ۱.۲ نداشته باشد.
Comment 6 You Have End 2016-11-20 14:19:08 UTC
سلام، فایل پیوستی رو مشاهده کنید
Comment 7 You Have End 2016-11-20 14:20:21 UTC
Created attachment 128887 [details]
Description about problem
Comment 8 You Have End 2016-11-20 14:25:02 UTC
بعد از مشاهده فایل پیوستی فونت گفته شده را از لینک زیر دانلود و نصب کن
http://www.uplooder.net/files/8ea4a8c14a84a3ccc34344cb4aeec6d0/fonts.zip.html
Comment 9 You Have End 2016-11-20 14:28:31 UTC
این مشکلاتی که شما در فایل پیوستی مثال زده اید به احتمال زیاد در نسخه 5.3 رفع خواهند شد
به هر حال باید با مشکلات کنار اومد
Comment 10 Buovjaga 2016-11-28 14:20:18 UTC
Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists in 5.3. Change to RESOLVED FIXED, if the problem went away.
Comment 11 Nima Az 2017-02-25 12:45:59 UTC
Hi,

Finally got to check the reported issue in 5.3.  The issue has not went away.

This is an obviously missing feature in LibreOffice.  There should be an easy way of changing the alignment of outline numberings to right-to-left when typing in an RTL language.  In RTL documents it's preferred that chapter numbers appear on the right, then following by other outline levels.
Comment 12 Nima Az 2017-03-10 12:31:46 UTC Comment hidden (obsolete)
Comment 13 Xisco Faulí 2017-03-10 12:45:44 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: d3676ceeec55a41337ce5e6bc596f4f100d0638e
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and 

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 14 Nima Az 2017-04-27 08:35:11 UTC Comment hidden (no-value)
Comment 15 QA Administrators 2018-04-28 02:31:32 UTC Comment hidden (obsolete)
Comment 16 Nima Az 2018-08-11 14:32:24 UTC
Hi,

I have checked and the bug still is present in the most recent version of LibreOffice.

Info from Help>About:

Version: 6.1.0.3
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: en-US (en_US); Calc: group threaded