Bug Hunting Session
Bug 103865 - Space between linline formula period at the end of sentence.
Summary: Space between linline formula period at the end of sentence.
Status: RESOLVED DUPLICATE of bug 103816
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.5.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-11 14:20 UTC by Ben
Modified: 2016-11-11 16:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Inline formula followed by period (1.19 KB, image/png)
2016-11-11 14:21 UTC, Ben
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben 2016-11-11 14:20:18 UTC
Description:
Whenever an inline formula is created at the end of a sentence followed by a period, there is extra space injected between the formula and period.
Example attached.

Steps to Reproduce:
1. Create text in Writer text editor
2. Add inline math formula
3. In text editing model, add period at the after the formula

Actual Results:  
Write a piece of text to a Writer document, add inline math formula at the end of text and then add a period in the text editing mode.

Expected Results:
No extra spacing


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.35 Safari/537.36
Comment 1 Ben 2016-11-11 14:21:29 UTC
Created attachment 128661 [details]
Inline formula followed by period
Comment 2 V Stuart Foote 2016-11-11 16:24:26 UTC
Issue as detailed in bug 103816 -- and the UI already provides functional controls for setting wrap on individual formulas, or adjusting the Frame -> Formula style. Also, option of adjusting default layout of formulas reducing the Spacing -> Borders category to reduce.  Bug 103816 is enhancement to implement a FormulaInline style that would capture defaults suitable to formula inline with text.

*** This bug has been marked as a duplicate of bug 103816 ***