Download it now!
Bug 103871 - Gaps inside justified Arabic words
Summary: Gaps inside justified Arabic words
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0
Keywords:
: 105079 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-11-11 17:34 UTC by Khaled Hosny
Modified: 2017-01-03 22:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample document (9.10 KB, application/vnd.oasis.opendocument.text)
2016-11-11 17:34 UTC, Khaled Hosny
Details
Sdreenshot (30.65 KB, image/png)
2016-11-11 17:36 UTC, Khaled Hosny
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Khaled Hosny 2016-11-11 17:34:17 UTC
Created attachment 128670 [details]
Sample document

Justified lines of text with mixed LTR and RTL text shows gaps (instead of Kashida) inside Arabic words.
Comment 1 Khaled Hosny 2016-11-11 17:36:11 UTC
Created attachment 128671 [details]
Sdreenshot
Comment 2 Commit Notification 2016-11-11 17:44:28 UTC
Khaled Hosny committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=553cfda502a1516673233e409f91372766da6c4d

tdf#103871: Set Kashida flag per glyph

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Khaled Hosny 2017-01-03 22:30:16 UTC
*** Bug 105079 has been marked as a duplicate of this bug. ***