Bug 103884 - 3D Object displayed as question mark (GTK3)
Summary: 3D Object displayed as question mark (GTK3)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks: GTK3 3D-Model 103768
  Show dependency treegraph
 
Reported: 2016-11-12 11:06 UTC by Xisco Faulí
Modified: 2017-12-26 19:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-11-12 11:06:12 UTC
1. Open attachment 128556 [details] in GTK2
2. Open attachment 128556 [details] in GTK3

Observed behaviour: in gtk2 the 3D object is displayed correctly while in gtk3 a question mark is displayed

Version: 5.3.0.0.alpha1+
Build ID: 60da087d7e182b58b63d4123c9bd96c82376d450
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)
Comment 1 MM 2016-11-20 23:02:50 UTC
For me the title is a bit wrong. I've got a quesionmark with 

Version: 5.3.0.0.alpha1+
Build ID: 43b5ca69aa545cf93eded55258d92d651917815f
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; VCL: gtk2; Layout Engine: new; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-11-18_05:17:53
Locale: en-US (en_US.UTF-8); Calc: single

Which is GTK2.....

Also reproduced with Version: 5.1.6.2
Build ID: 07ac168c60a517dba0f0d7bc7540f5afa45f0909
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: single
Comment 2 MM 2016-11-20 23:36:22 UTC
Also reproduced with

Version: 5.3.0.0.alpha1+
Build ID: d881f99c7a911a433ef624e891df3291886cf62b
CPU Threads: 2; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; Layout Engine: new; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-11-20_10:55:31
Locale: en-US (en_US.UTF-8); Calc: single
Comment 3 Buovjaga 2016-11-25 13:21:48 UTC
GTK2 works for me as do all other backends except GTK3.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: f1eb0bf75296ee9c59241507a1e03f4de770afa1
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on November 25th 2016
Comment 4 Caolán McNamara 2016-11-29 15:49:55 UTC
gtk3 specific part of this is missing opengl support, the first requirement of this is epoxy support as per todays email to dev list.
Comment 5 Commit Notification 2017-09-07 08:05:57 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9f28a9e6593fcb9031cd1f80b073c62e624eddd8

Related: tdf#103884 poke libgltf towards core profile

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2017-09-08 08:50:11 UTC
libgltf has to stick to core opengl profile to have a chance here, still doesn't work, but with a little change or two I get something visible, albeit in black and white a distorted
Comment 7 Commit Notification 2017-10-30 07:22:29 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=08a43cc97ccf88faa9d3a04afc3aacd2c885a2d1

related: tdf#103884 remove gltf/collada feature

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2017-11-02 09:43:55 UTC
feature removed for all backends, so that fixes this in that sense
Comment 9 Xisco Faulí 2017-12-26 19:06:41 UTC
Verified in

Version: 6.1.0.0.alpha0+
Build ID: 2bf1cc7372088ec31ac5f0fb60de57feda59d3b7
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded