Bug 103905 - After discarding document recovery, Writer launches
Summary: After discarding document recovery, Writer launches
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Document-Recovery
  Show dependency treegraph
 
Reported: 2016-11-13 13:45 UTC by Telesto
Modified: 2020-01-03 15:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-11-13 13:45:20 UTC
Description:
When I discard a Document Recovery within +/- 20 seconds after showing up, it will open a writer document instead of Start Center. If I wait longer Start Center will open. It's a LO 5.3.0.0 only bug.



Steps to Reproduce:
1. Launch LibreOffice
2. Open Impress (for example)
3. Add some content
4. Go to activity monitor
5. Quit LibreOffice with force
6. Restart LibreOffice
7. Discard Document Recovery
8. Accept the warning.

Actual Results:  
Writer will start with a blank document

Expected Results:
Go to Start Center


Reproducible: Always

User Profile Reset: YES

Additional Info:
Version: 5.3.0.0.alpha1+
Build ID: 0d75c63a307616b8327b1828d2ab973f4713822b
CPU Threads: 4; OS Version: Mac OS X 10.12.1; UI Render: default; Layout Engine: new; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-11-12_00:32:05
Locale: en-US (en_US.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_1) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14
Comment 1 Alex Thurgood 2016-11-14 08:53:34 UTC
Hmm, sounds like a thread release/scheduling problem again.
Comment 2 Yousuf Philips (jay) (retired) 2017-10-07 09:28:45 UTC
This happens on linux as well.
Comment 3 Roger Magana 2017-10-17 00:34:28 UTC
Seems to be reproducible on 5.4.2.X
Comment 4 QA Administrators 2018-10-18 02:49:54 UTC Comment hidden (obsolete)