Bug 103908 - Vertical text in table header is rendered with overlapping characters
Summary: Vertical text in table header is rendered with overlapping characters
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: regression
Depends on: HarfBuzz
Blocks:
  Show dependency treegraph
 
Reported: 2016-11-13 14:27 UTC by Joerg
Modified: 2017-07-05 09:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
ODT_FileWithTheAffectedTable (10.20 KB, application/vnd.oasis.opendocument.text)
2016-11-13 14:28 UTC, Joerg
Details
LO5.3Alpha1+_BrokenRenderingOfVerticalText (139.33 KB, image/png)
2016-11-13 14:29 UTC, Joerg
Details
LO5.2.1.2_CorrectRenderingOfVerticalText (124.46 KB, image/png)
2016-11-13 14:29 UTC, Joerg
Details
Cut down odt file showing table at the end- refer PDFs for rendering. (9.55 MB, application/vnd.oasis.opendocument.text)
2016-11-24 01:05 UTC, Steve Edmonds
Details
PDF of file with vertical text bug as it shows generated with LO5.1.4 (and AOO) (355.39 KB, application/pdf)
2016-11-24 01:07 UTC, Steve Edmonds
Details
PDF of file with vertical text bug as it shows generated with LO5.2.3.3 (462.85 KB, application/pdf)
2016-11-24 01:09 UTC, Steve Edmonds
Details
rendered pdf with vertical text (90 deg rotation) having a new line CTRL+ENTER after "can't" (8.87 KB, application/pdf)
2016-11-26 14:58 UTC, Andrei B.
Details
source odt for the "new line" pdf above (10.18 KB, application/vnd.oasis.opendocument.text)
2016-11-26 14:58 UTC, Andrei B.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joerg 2016-11-13 14:27:08 UTC
Description:
The vertical text inside the table in attached file was correctly rendered in LO5.2.1.2, but is no longer in Version: 5.3.0.0.alpha1+ (x64) Build-ID: 79258677f04c59d194bbfd032230c7a2fc4fea80



Actual Results:  
see attachment from 5.3Alpha1+

Expected Results:
same output as in the screenshot from LO5.2.1.2


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 Joerg 2016-11-13 14:28:11 UTC
Created attachment 128723 [details]
ODT_FileWithTheAffectedTable
Comment 2 Joerg 2016-11-13 14:29:13 UTC
Created attachment 128724 [details]
LO5.3Alpha1+_BrokenRenderingOfVerticalText
Comment 3 Joerg 2016-11-13 14:29:57 UTC
Created attachment 128725 [details]
LO5.2.1.2_CorrectRenderingOfVerticalText
Comment 4 Xisco Faulí 2016-11-14 10:05:03 UTC
I can't reproduce it in

Version: 5.3.0.0.alpha1+
Build ID: fef32a42c8bd8fd640d6c9cdc2f839fb43ad490c
CPU Threads: 4; OS Version: Linux 4.8; UI Render: GL; VCL: gtk3; Layout Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 5 Xisco Faulí 2016-11-14 11:33:38 UTC Comment hidden (obsolete)
Comment 6 Joerg 2016-11-14 19:52:40 UTC
I just tried as with the following build again, and the problem still appears! Maybe it's a Windows specific problem?

Version: 5.3.0.0.alpha1+ (x64)
Build-ID: c5f5b3e5334c52502c1de28828a44ad469c68850
CPU-Threads: 4; BS-Version: Windows 6.1; UI-Render: Standard; Layout Engine: new; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2016-11-14_06:28:54
Gebietsschema: de-DE (de_DE); Calc: group
Comment 7 Xisco Faulí 2016-11-15 09:27:00 UTC
Does using the old layout fix the issue? Try to launch LibroOffice with SAL_NO_COMMON_LAYOUT=1 and compare the results...
Comment 8 Joerg 2016-11-15 22:38:18 UTC
The rendering with Version: 5.3.0.0.alpha1+ (x64) Build-ID: c5f5b3e5334c52502c1de28828a44ad469c68850 is correct, if SAL_NO_COMMON_LAYOUT=1 is defined as environment variable, if it's not defined, the rendering is broken.
Comment 9 Steve Edmonds 2016-11-24 00:40:14 UTC Comment hidden (off-topic)
Comment 10 Steve Edmonds 2016-11-24 01:05:07 UTC Comment hidden (off-topic)
Comment 11 Steve Edmonds 2016-11-24 01:07:45 UTC Comment hidden (off-topic)
Comment 12 Steve Edmonds 2016-11-24 01:09:22 UTC Comment hidden (off-topic)
Comment 13 Joerg 2016-11-24 07:06:49 UTC Comment hidden (off-topic)
Comment 14 Andrei B. 2016-11-26 14:56:43 UTC Comment hidden (off-topic)
Comment 15 Andrei B. 2016-11-26 14:58:11 UTC Comment hidden (off-topic)
Comment 16 Andrei B. 2016-11-26 14:58:52 UTC Comment hidden (off-topic)
Comment 17 Joerg 2016-11-26 15:03:14 UTC Comment hidden (off-topic)
Comment 18 Andrei B. 2016-11-26 15:09:34 UTC Comment hidden (off-topic)
Comment 19 Telesto 2016-11-29 21:25:14 UTC
Rendering of Vertical Text seems to be fine with:
Version: 5.4.0.0.alpha0+
Build ID: 4130c8def811d1dcc87eacaa8ae48ba02738a790
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-11-29_01:03:18
Locale: nl-NL (nl_NL); Calc: CL
Comment 20 Buovjaga 2016-11-30 13:03:32 UTC
(In reply to Telesto from comment #19)
> Rendering of Vertical Text seems to be fine with:
> Version: 5.4.0.0.alpha0+
> Build ID: 4130c8def811d1dcc87eacaa8ae48ba02738a790
> CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
> TinderBox: Win-x86@42, Branch:master, Time: 2016-11-29_01:03:18
> Locale: nl-NL (nl_NL); Calc: CL

This might be due to some fixes in the new layout engine.

Joerg: could you try a fresh build http://dev-builds.libreoffice.org/daily/master/Win-x86@42/current/

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 21 Joerg 2016-12-21 22:30:17 UTC
I just verified this with
libreoffice-5-3~2016-12-16_12.19.09_LibreOfficeDev_5.3.0.0.beta2_Win_x86_en-US_de_ar_ja_ru_vec_qtz
and
libo-master~2016-11-29_23.29.46_LibreOfficeDev_5.4.0.0.alpha0_Win_x86

In both versions thevertical text is drawn correct!
Comment 22 Buovjaga 2016-12-27 22:33:16 UTC
Thanks for testing. I will add bug 89870 to the dependencies to add this to the pile of bugs that the new engine fixed.