Download it now!
Bug 103925 - FILEOPEN RTF: unexpected blinking text
Summary: FILEOPEN RTF: unexpected blinking text
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:5.4.0 target:5.3.0.1
Keywords: bibisected, bisected, filter:rtf, regression
Depends on:
Blocks: RTF
  Show dependency treegraph
 
Reported: 2016-11-14 11:36 UTC by Jacobo Aragunde Pérez
Modified: 2017-03-04 00:18 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Test case (52.95 KB, application/rtf)
2016-11-14 11:36 UTC, Jacobo Aragunde Pérez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jacobo Aragunde Pérez 2016-11-14 11:36:31 UTC
Created attachment 128744 [details]
Test case

Most text in the attached rtf document blinks when imported into LibreOffice. This doesn't happen when opened with Word 2010.

Blinking happens because the font effect "blinking" is enabled, it has nothing to do with the rendering. It can be disabled in Format -> Character -> Font effects.

FTR, the document is a template publicly available from: http://www.conselleriadefacenda.es/areas-tematicas/patrimonio/rexistro-xeral-de-contratistas/formularios/-/publicador/rKVz5takIXIG/content/declaracion-artigo-60-trlcsp
Comment 1 Dennis Roczek 2016-11-14 11:49:21 UTC
Version: 5.2.2.2
Build-ID: 8f96e87c890bf8fa77463cd4b640a2312823f3ad
CPU-Threads: 4; BS-Version: Windows 6.2; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group

CONFIRMED. 

MSO2013 Word does not blink.
same with Wordpad of Win10.

even when removing the direct formatting the blinking still happens. Didn't even know that we support blinking now. :-(
Comment 2 Xisco Faulí 2016-11-14 11:54:14 UTC
it doesn't blink in

Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)
Comment 3 raal 2016-11-15 14:43:09 UTC
This seems to have begun at the below commit.
Adding Cc: to Miklos Vajna ; Could you possibly take a look at this one? Thanks

ed217457c1968223724813203be6b4fb6670aaa5 is the first bad commit
commit ed217457c1968223724813203be6b4fb6670aaa5
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sat Jan 9 09:38:53 2016 -0800
    source sha:ac6bfd85df271b650dbd24b45391dac346ecd72c
	
author	Miklos Vajna <vmiklos@collabora.co.uk>	2016-01-06 07:23:20 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2016-01-06 07:59:07 (GMT)
commit	ac6bfd85df271b650dbd24b45391dac346ecd72c (patch)
tree	a022d1d9270f38cf49b5b30b9e36a18cb51c1ad3
parent	a30a36b3c70e64b62add9f3c5376202b9682851f (diff)
tdf#92045 DOCX import: <w:effect w:val="none"/> doesn't mean blinking
	
git bisect log
# bad: [6380ca07b05f68dedcaa379302cfe1fa478571c4] source sha:60b74fe1775e647545d2da1fcc58a4c63ec18aa5
# good: [1f670510f08cb800cbae2a1dd6ea70d3542e4721] source sha:49c2b9808df8a6b197dec666dfc0cda6321a4306
git bisect start 'origin/master' 'oldest'
# bad: [38f37b8ec1a2d199bb957cfd2581df7d1b273b74] source sha:c0da1080b61a1d51654fc34fdaeba373226065ff
git bisect bad 38f37b8ec1a2d199bb957cfd2581df7d1b273b74
# bad: [6998931a34ad75eb555f882fbed223e585548721] source sha:1fbd073828ef52f5206aed4643226bae9fb85f4f
git bisect bad 6998931a34ad75eb555f882fbed223e585548721
# good: [0ea9534d0f4c90833e004706de7c11abe5bc522d] source sha:97361478e64f11330f7f7aea819d60c7562fb0f6
git bisect good 0ea9534d0f4c90833e004706de7c11abe5bc522d
# good: [5e4c9cfe6cb41f11e1fb2369ecc31fdfe0e08e82] source sha:38e965fe0fcabffadb8fabe6756313b4f37daad5
git bisect good 5e4c9cfe6cb41f11e1fb2369ecc31fdfe0e08e82
# bad: [fad9c309c7a6c20b3de2b0ba904eb5ea5eb53f7e] source sha:f6f73d2e40712dadf69cd73a34d006988669978c
git bisect bad fad9c309c7a6c20b3de2b0ba904eb5ea5eb53f7e
# bad: [c58fedf998ad74d09c7faf9c7f04dc2461a5c574] source sha:7c73152f642f331c5640a98b256013cb88180a1d
git bisect bad c58fedf998ad74d09c7faf9c7f04dc2461a5c574
# good: [17e9c8f9c6c901e680319048ef1466975c92fa54] source sha:22480b20130d10f4691cdf0a658040be7f36e47b
git bisect good 17e9c8f9c6c901e680319048ef1466975c92fa54
# bad: [97dd9584fb7ebf12fe5c2d1ba9892474869c6019] source sha:ef16f72de9e7abf563239b2ff4083a73430f839f
git bisect bad 97dd9584fb7ebf12fe5c2d1ba9892474869c6019
# good: [d40b3b74e8a1de221c59089bbe50a266803318ad] source sha:7f36d2e25572978ee6ee79a4089db81c191df260
git bisect good d40b3b74e8a1de221c59089bbe50a266803318ad
# good: [5ec23f30de80b4e36ffb5332f72d44197d336bab] source sha:4ae7b66286f391839b0d8d6c5a73ee7849eb4d1f
git bisect good 5ec23f30de80b4e36ffb5332f72d44197d336bab
# good: [7be641a2e1c6149ead61f3d7437f934d087afffd] source sha:6c1cab568039aca82a744badde335f83413beaa3
git bisect good 7be641a2e1c6149ead61f3d7437f934d087afffd
# good: [b0a3b8b18d9213d8a2a3a745a79dae663a57deb6] source sha:a30a36b3c70e64b62add9f3c5376202b9682851f
git bisect good b0a3b8b18d9213d8a2a3a745a79dae663a57deb6
# bad: [ed217457c1968223724813203be6b4fb6670aaa5] source sha:ac6bfd85df271b650dbd24b45391dac346ecd72c
git bisect bad ed217457c1968223724813203be6b4fb6670aaa5
# first bad commit: [ed217457c1968223724813203be6b4fb6670aaa5] source sha:ac6bfd85df271b650dbd24b45391dac346ecd72c
Comment 4 Jacobo Aragunde Pérez 2016-11-16 09:31:53 UTC
This comment is in the surrounding code of that patch:

// The file-format has many character animations. We have only
// one, so we use it always. Suboptimal solution though.

My first guess was the text is using some character effect/animation that is being translated as blinking into LibreOffice, but I don't see any effect on those chars in the original file when opened with Word.

Besides, if you save the document as docx in Word and then open that result, the bug cannot be reproduced.
Comment 5 Miklos Vajna 2016-12-09 12:41:13 UTC
The problem is that the RTF tokenizer sends WW8-style values (0..8) for the blink attribute, while the OOXML tokenizer uses a "none" token. I'll update the RTF tokenizer to use the OOXML tokens as well to have this fixed.
Comment 6 Commit Notification 2016-12-09 18:42:03 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c260580daa4fe78093265c1359c4d54677d76470

tdf#103925 RTF import: fix handling of \animtext0

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2016-12-13 11:45:34 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=26217b01d5630ddf63c60b4400d3a58d3c0dd789&h=libreoffice-5-3

tdf#103925 RTF import: fix handling of \animtext0

It will be available in 5.3.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 vihsa 2017-02-28 05:07:47 UTC
verified. Version: 5.4.0.0.alpha0+
Build ID: febc116

downloaded attachment 128744 [details]
the text does not blink