Bug 103933 - FILESAVE: DOCX Corrupted file after roundtrip
Summary: FILESAVE: DOCX Corrupted file after roundtrip
Status: RESOLVED DUPLICATE of bug 103982
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2016-11-15 10:47 UTC by Xisco Faulí
Modified: 2016-11-22 15:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-11-15 10:47:17 UTC
Steps:
1. Open attachment 86188 [details]
2. Save is as .DOCX
3. Open the document in MS Office

Observed behaviour: MS Office displays a error message Corrupted File
Expected bahaviour: MS Office can open the document

Reproduced in 

Version: 5.3.0.0.alpha1+
Build ID: 757a60d01dd152aadab2ba3c8224252481ce8a88
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout
Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 1 Xisco Faulí 2016-11-15 15:19:07 UTC
Regression introduced by:

author	Miklos Vajna <vmiklos@collabora.co.uk>	2014-12-04 09:42:40 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2014-12-04 10:25:38 (GMT)
commit	a5a836d8c43dc9cebbbf8af39bf0142de603a7c6 (patch)
tree	5211f53b880421d89cfbcf36688d6ea29dcbb7be
parent	5f0f3d4e91e9eb1d1f60b0cd073e7bbd8ea38c29 (diff)

DOCX filter: effect extent should be part of the margin

OOXML has an object size (extent) a size including effects like shadow (effect
extent) and the margin (top/bottom/left/right distance). Our doc model doesn't
have an explicit "effect extent", but to have the intended layout, we at least
need the spacing of the effect around flys (even if a number of effects are not
rendered). Fix this by adding the effect extent to the margin; if we still have
the effect extent grab-bag around, then this can be undone during export.

Adding CC: to Miklos Vajna
Comment 2 Xisco Faulí 2016-11-17 12:34:16 UTC
Another file affected by the same problem: attachment 111442 [details]
Comment 3 Xisco Faulí 2016-11-18 18:05:52 UTC

*** This bug has been marked as a duplicate of bug 103982 ***
Comment 4 Xisco Faulí 2016-11-22 15:13:55 UTC
follow-up bug created: bug 104115