Bug 103951 - Performance regression when opening/scrolling in a particular spreadsheet
Summary: Performance regression when opening/scrolling in a particular spreadsheet
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf, regression
Depends on:
Blocks:
 
Reported: 2016-11-16 08:33 UTC by Aron Budea
Modified: 2016-12-05 20:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2016-11-16 08:33:48 UTC
Open attachment 85396 [details] from bug 69069.
Opening in 5.3 daily build it takes about twice as long as in 5.2.3.3 (20-25s -> ~45s for me).
Scrolling the sheet with the chart (Grafik) is also sluggish, while it isn't in 5.2.

I tested in Windows 7, if it can't be reproduced in Linux, adjust OS field accordingly.

Version: 5.3.0.0.alpha1+
Build ID: 0d6f974b97597744119db9dc3d193aeeb8f9d3fa
CPU Threads: 4; OS Version: Windows 6.1; UI Render: GL; Layout Engine: new; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-11-11_23:56:36
Locale: hu-HU (hu_HU); Calc: CL
Comment 1 m.a.riosv 2016-11-19 16:14:55 UTC
Reproducible.
Version: 5.3.0.0.alpha1+
Build ID: c64b8ffe851d3320a15071fa4bc4b0f12e9939d5
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; Layout Engine: new; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-11-11_01:34:42
Locale: es-ES (es_ES); Calc: CL
Comment 2 Aron Budea 2016-12-05 20:57:56 UTC
Seems to be fixed in 5.3beta1 / Windows 7. Closing as WFM.