Bug Hunting Session
Bug 103977 - Menu items flicker on mouse-over with default GDI rendering and new HarfBuzz based common layout engine
Summary: Menu items flicker on mouse-over with default GDI rendering and new HarfBuzz ...
Status: RESOLVED DUPLICATE of bug 105863
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-17 10:22 UTC by Telesto
Modified: 2017-04-23 09:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screencast (218.00 KB, video/x-msvideo)
2016-11-17 10:23 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-11-17 10:22:15 UTC
Description:
When I move my mouse over menu items the will flicker a bit. A specially noticeable with menu items with a icon. 

Steps to Reproduce:
1. Open LO Writer
2. Choose a menu (for example Format)
3. Hover over 

Actual Results:  
Menu items flicker

Expected Results:
Menu items do not 'blink'


Reproducible: Always

User Profile Reset: YES

Additional Info:
Tested with
Version: 5.3.0.0.alpha1+
Build ID: b223028d65d24ffcd8e27974c29c2744a5df6227
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-16_22:50:22
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2016-11-17 10:23:18 UTC
Created attachment 128808 [details]
Screencast
Comment 2 V Stuart Foote 2016-11-18 03:30:25 UTC
This is a known limitation of the GDI rendering implemented with the new HarfBuzz common text layout engine.

If you are able to activate OpenGL rendering the UI will be stable, but there are some issues with OpenGL rendering particularly using the sm Math formula editor.
Comment 3 Khaled Hosny 2016-11-18 04:33:12 UTC
I can’t reproduce such flickering.
Comment 4 Telesto 2016-11-18 11:09:52 UTC
(In reply to V Stuart Foote from comment #2)
> This is a known limitation of the GDI rendering implemented with the new
> HarfBuzz common text layout engine.
> 
> If you are able to activate OpenGL rendering the UI will be stable, but
> there are some issues with OpenGL rendering particularly using the sm Math
> formula editor.

You're right, with OpenGL everything everything is working normal. Thanks for the tip!
Comment 5 Telesto 2017-02-08 21:25:06 UTC

*** This bug has been marked as a duplicate of bug 105863 ***