Download it now!
Bug 103990 - FILEOPEN: DOCX: text inside textbox is cropped
Summary: FILEOPEN: DOCX: text inside textbox is cropped
Status: RESOLVED DUPLICATE of bug 106132
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX-Textbox
  Show dependency treegraph
 
Reported: 2016-11-17 16:46 UTC by Xisco Faulí
Modified: 2017-07-04 02:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-11-17 16:46:20 UTC
Steps:
1. Open attachment 97512 [details]
2. Check line 'To create a stand-alone virtual machine template'

Observed behaviour: line is cropped

Reproduced in 

Version: 5.3.0.0.alpha1+
Build ID: 757a60d01dd152aadab2ba3c8224252481ce8a88
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout
Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 1 Xisco Faulí 2016-11-17 16:48:42 UTC
Regression introduced by:

author	Miklos Vajna <vmiklos@collabora.co.uk>	2016-10-25 07:05:47 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2016-10-25 09:32:01 (GMT)
commit	c761df1e42fd11acc5fc05b0baacd803c3788ca6 (patch)
tree	6ed550b92aefe19191fa14b462894714907baa3c
parent	fab262f115e5c0e6d43b65e376241152ddff82b3 (diff)

tdf#84678 DOCX import: fix handling of textbox margins
Regression from commit d379d18666aa42031359ca8eb34b0021960347ae (oox:
import WPS shape with text as shape with textbox, 2014-06-18), the
problem for a long time was that in Writer text frames without borders
couldn't have text margins, either.

Recently a compat setting was added in the WW8 filter for this
situation, so use that in the DOCX import as well, and improve
SwTextBoxHelper to handle the margin properties.

Adding Cc: to Miklos Vajna
Comment 2 Xisco Faulí 2017-02-23 10:02:34 UTC Comment hidden (obsolete)
Comment 3 Justin L 2017-07-04 02:36:05 UTC

*** This bug has been marked as a duplicate of bug 106132 ***