Download it now!
Bug 104012 - RTF (special) paste broken in v5.2.x
Summary: RTF (special) paste broken in v5.2.x
Status: RESOLVED DUPLICATE of bug 101828
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks: RTF Paste
  Show dependency treegraph
 
Reported: 2016-11-18 16:36 UTC by ChrisAIX
Modified: 2016-12-27 10:32 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
details of bibisect within win32-5.2 repository (3.03 KB, text/plain)
2016-11-23 15:58 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ChrisAIX 2016-11-18 16:36:27 UTC
Wheny trying to copy & paste formatted / coloured text into writer it will be pasted as plain text. Also paste special (via right mouse click) does not show RTF selection item.

This issue arises only in writer v5.2.x (I tested release versions: 5.2.2 and 5.2.3)

In v 5.1.6 everything works fine.
I've tested it on Windows 7 + 10 with the same result.

Source programs:

*    IBM Notes (Lotus Notes) --> copy from a mail
*    SQuirrel (http://squirrel-sql.sourceforge.net/)
        --> SQL Editor > right mouse button -> Copy in RTF 
            - this should paste coloured text and preformatted text type  - but it will be pasted default style as plain text.

Pasting in Writer v5.2.x is always plain (unformatted) text - special paste does not show the RTF field (as it will shown in LO v5.1.6 and in old OpenOffice)
Comment 2 Aron Budea 2016-11-19 03:43:03 UTC
Confirmed with 5.2.0.4 / Windows 7. Works fine in 5.1.6.2. => regression

I used WordPad, set a piece of text red, then copied it, and tried to paste it in Writer. In 5.1.6.2 there's "Formatted text (RTF)" option in Paste Special dialog, since 5.2.0.4 that option is missing.
Comment 3 Yousuf Philips (jay) (retired) 2016-11-22 13:30:54 UTC
Also on linux when coming text from 5.1.5 to master.

Version: 5.3.0.0.alpha1+
Build ID: 883024d657fb45c7da459017d2f936aac5644bfb
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; VCL: gtk2; Layout Engine: new; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-11-21_22:42:51
Locale: en-US (en_US.UTF-8); Calc: group
Comment 4 Terrence Enger 2016-11-23 15:58:20 UTC
Created attachment 128966 [details]
details of bibisect within win32-5.2 repository

For testing I did the following ...
(*) In WordPad, created a .rtf with two paragraphs, one in Arial 10 point.
(*) In WordPad, select the whole document and Copy.
(*) In LibreOffice, Paste, variously by <Ctrl>+V, <Ctrl>+<Shift>+V,
    <Alt>+E P.  Only <Ctrl>+Shift+V offered the "Paste Special" dialog
    with a selection what to paste.  When that dialog offered
    "Formatted text [RTF]", all ways of pasting pasted with the fonts
    from the copy-from document.  Otherwise, all ways of pasting
    pasted in Liberation Serif 12 point.


Working on Windows Vista in the win32-5.2 bibisect repository I see ...

          commit    s-h       date
          --------  --------  -------------------
    good  e40edc1a  416526cf  2016-03-10 10:09:07
    bad   81cc3639  36bf1324  2016-03-10 10:11:04

The commit message is ...

    terry@lynn-stretch:~/lo_hacking/git/libo6$ git log -1 36bf1324
    commit 36bf13247b01075b533b127c7e5ffc760f9642f8
    Author: Oliver Specht <oliver.specht@cib.de>
    Date:   Wed Mar 9 16:19:51 2016 +0100

        tdf#97591: mark RTF clipboard format as text/rtf
    
        text/rtf replaces text/richtext which is not RTF
    
        Change-Id: I2be750b595ba23ed75698b68c0d4ffd8f3a12870
        Reviewed-on: https://gerrit.libreoffice.org/23086
        Reviewed-by: Oliver Specht <oliver.specht@cib.de>
        Tested-by: Oliver Specht <oliver.specht@cib.de>

I am removing keyword bibisectRequest and adding bisected.
Comment 5 Xisco Faulí 2016-11-23 16:10:22 UTC
Hi Terrence,
thanks for bisecting this bug, it looks like a duplicate of bug 101828 as it's the same commit that introduced both bugs

*** This bug has been marked as a duplicate of bug 101828 ***
Comment 6 ChrisAIX 2016-12-27 10:32:25 UTC
Is there a chance to get this bug fixed either in 5.2.x or 5.3.x ?

I mean - an Office Program that is not able to cut & paste anything else than pure plain text does not really make sense - or am I wrong?

This bug has not been been fixed in latest version (5.2.4.x).

Any Comments?