Bug 104015 - PPTX import: Title shape does not inherit fill properties from slide master
Summary: PPTX import: Title shape does not inherit fill properties from slide master
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: Tamás Zolnai
URL:
Whiteboard: target:5.3.0 target:5.2.4
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2016-11-18 18:01 UTC by Tamás Zolnai
Modified: 2016-11-27 09:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Tes document with title shape (18.74 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2016-11-18 18:01 UTC, Tamás Zolnai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Zolnai 2016-11-18 18:01:02 UTC
Description:
After opening the attached PPTX file, can't see the red bakcground fill of the title shape on first slide.

Steps to Reproduce:
1. Open PPTX file
2. Check title shape of first slide

Actual Results:  
Title shape has no background fill set.

Expected Results:
Title shape should have red background fill.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.71 Safari/537.36
Comment 1 Tamás Zolnai 2016-11-18 18:01:56 UTC
Created attachment 128851 [details]
Tes document with title shape
Comment 2 Xisco Faulí 2016-11-18 18:18:02 UTC
Confirmed.

Regression introduced by:

author	Zolnai Tamás <tamas.zolnai@collabora.com>	2014-11-28 18:57:58 (GMT)
committer	Zolnai Tamás <tamas.zolnai@collabora.com>	2014-11-30 13:26:53 (GMT)
commit	81cd386facedfbb15be6dffc10351262abf733f3 (patch)
tree	6e55d7bc03aad2932b7723fdc7696b162795731b
parent	ef8e38266b13800518830917a71dde4d3ee8f7ef (diff)

bnc#904423: Text(box) is rendered white on white when it is not
The problem was that the background color defined by theme
was not imported correctly, because the different fill
style comes from different sources (master slide, theme,
direct formatting) were applied on the shape in wrong order.

To solve this we need to store master slide defined fill style
in a different variable so theme style can be applied after master
slide defined style but before direct formatting.
Comment 3 Commit Notification 2016-11-18 22:43:23 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8d613870b2cd2e3e4396b4fa97dbd8080fda8f52

tdf#104015: PPTX import: Title shape does not inherit fill properties

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2016-11-26 22:51:21 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=502b8d0d4178174130609b4b3085714864fb7b64&h=libreoffice-5-2

tdf#104015: PPTX import: Title shape does not inherit fill properties

It will be available in 5.2.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.