Download it now!
Bug 104023 - track changes - show changes is always marked as enabled, even after disabling
Summary: track changes - show changes is always marked as enabled, even after disabling
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: high major
Assignee: Justin L
URL:
Whiteboard: target:5.3.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Track-Changes 89991
  Show dependency treegraph
 
Reported: 2016-11-19 04:22 UTC by Justin L
Modified: 2017-04-25 06:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Justin L 2016-11-19 04:22:33 UTC
Description:
Edit - Track changes - Show Changes ALWAYS has a check-box in it.  Clicking on Show changes does turn off showing changes, but cannot turn it back on.

Regression in 5.3 development branch.  Tested using Linux daily dbgutil narrowed it down to around Sept 8 and then I identified the regression as
author	Noel Grandin <noel@peralex.com>	2016-09-07 11:10:40 (GMT)
commit	847e004e65ec3c35acff607588d15cd75a84f121
   convert nsRedlineMode_t to typed_flags

because these two lines are not equivalent:
-                bSet = (eMode & nMask) == nMask;
+                bSet = bool(eMode & nMask);

attachment 114078 [details] can be used as a test document.  It already has Show Changes enabled, with green changes showing.  Turning Show Changes off DOES turn off the green marking, but the checkbox still indicates that Show Changes is active, and clicking on it again does not shown the green changes again.

Steps to Reproduce:
1. Edit Menu - track changes - show changes is marked as enabled. click on it.


Actual Results:  
go back and it is still marked as enabled.

Expected Results:
On a new document - show changes should not even be enabled.  Clicking on it should have marked it as disabled anyways.


Reproducible: Always

User Profile Reset: No

Additional Info:
Major severity - an important feature is completely disabled.


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 Xisco Faulí 2016-11-19 13:17:52 UTC
Moving it to NEW as the problematic commit has been identified
Comment 2 Commit Notification 2016-11-21 06:18:25 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bbe19c1312500c63748583eb2e64f5cd1190942c

tdf#104023 - fix wrong boolean logic for RedlineFlags

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Nikos Platis 2016-11-22 18:53:00 UTC
Let me note that probably the same issue is present in LO-Fresh 5.2.3 (Arch Linux). In "Edit" menu there is only a (non-functional) check-box menu entry "Track changes", (not) working as described in the bug report; there is no sub-menu with relevant entries, as in LO-Still 5.1.6.

So if Fresh is going to see further releases before 5.3, this should be fixed there as well.
Comment 4 Justin L 2016-11-22 19:13:10 UTC
(In reply to Nikos Platis from comment #3)
> Let me note that probably the same issue is present in LO-Fresh 5.2.3 (Arch
> Linux).

Hi Nikos.  I just checked and "convert nsRedlineMode_t to typed_flags" was never back-ported to LO 5.2.

> In "Edit" menu there is only a (non-functional) check-box menu entry
> "Track changes", (not) working as described in the bug report; there is no
> sub-menu with relevant entries, as in LO-Still 5.1.6.

Are you refering to using Writer?  In Ubuntu and LO 5.2.3.2 I do have a submenu for Edit - Track Changes (and no checkbox for Edit - Track Changes).  The same is true for the libreoffice-5-2 development branch.  So I cannot replicate your report.

> So if Fresh is going to see further releases before 5.3, this should be
> fixed there as well.

Probably it will be best to create a new bug report if you can consistently replicate the problem - since it will be a different one than was fixed by this bug-report.
Comment 5 Justin L 2017-04-25 06:59:48 UTC
In 5.3, there is also a VIEW - Track Changes which is a simple checkbox.  It is identical to EDIT - Track Changes - Show.  Perhaps that is what Nikos was looking at.