Bug 104039 - FILESAVE: DOC Shadow arrow lost after RT
Summary: FILESAVE: DOC Shadow arrow lost after RT
Status: RESOLVED DUPLICATE of bug 104144
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.0.0.beta2
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:doc, regression
Depends on:
Blocks: DOC
  Show dependency treegraph
 
Reported: 2016-11-19 20:36 UTC by Xisco Faulí
Modified: 2017-02-10 21:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (17.50 KB, application/msword)
2016-11-19 20:36 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-11-19 20:36:36 UTC
Created attachment 128879 [details]
sample

Steps:
1. Open attached document
2. Save it as a new .DOC file
3. Open the new file

Observed behaviour: Shadow arrow is gone after roundtrip

Reproduced in 

Version: 5.3.0.0.alpha1+
Build ID: 757a60d01dd152aadab2ba3c8224252481ce8a88
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout
Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 1 MM 2016-11-20 00:56:30 UTC
Unconfirmed with v5.1.6.2 under ubuntu 16.04 x64.
Confirmed with v5.2.0.0 beta2 under ubuntu 16.04 x64.
Confirmed with v5.2.3.3 under ubuntu 16.04 x64.
Comment 2 raal 2016-11-26 09:58:27 UTC
This seems to have begun at the below commit.
Adding Cc: to Miklos Vajna; Could you possibly take a look at this one? Thanks

 author	Miklos Vajna <vmiklos@collabora.co.uk>	2016-01-26 12:21:28 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2016-01-26 12:21:54 (GMT)
commit	3915bf2dc877d5f1140798e24933db0f21386a4a (patch)
tree	bcc1034371fa11953556b3400f520ee593760727
parent	09e46424c510924bae09c6e0147095e2958fa009 (diff)
tdf#95376 DOCX import: fix incorrectly indented tab stops

 6158dc3b35af692504c2f49e945df8059eebf092 is the first bad commit
commit 6158dc3b35af692504c2f49e945df8059eebf092
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sat May 14 22:12:17 2016 -0700

    source sha:5ffd2c1595d1f67f5e4b14e48188a1f37f1956b5
 git bisect log
# bad: [6380ca07b05f68dedcaa379302cfe1fa478571c4] source sha:60b74fe1775e647545d2da1fcc58a4c63ec18aa5
# good: [1f670510f08cb800cbae2a1dd6ea70d3542e4721] source sha:49c2b9808df8a6b197dec666dfc0cda6321a4306
git bisect start 'origin/master' 'oldest'
# good: [38f37b8ec1a2d199bb957cfd2581df7d1b273b74] source sha:c0da1080b61a1d51654fc34fdaeba373226065ff
git bisect good 38f37b8ec1a2d199bb957cfd2581df7d1b273b74
# good: [11ae494d8c566f23e0ef84ba0cc25fb1388b67f7] source sha:470cfa9860232ab70e017e6084d80f80d469555c
git bisect good 11ae494d8c566f23e0ef84ba0cc25fb1388b67f7
# good: [ee4cfd75d2452b8c416b4ec27358f7a905d6f5cf] source sha:aa544a002e534a313ad9dd365e80f052789d9963
git bisect good ee4cfd75d2452b8c416b4ec27358f7a905d6f5cf
# bad: [d4576510090f82fe28ee9ee0a9e299fe2541f06c] source sha:7e55fbab6348c2a844fc7ecca8de61416db8fdae
git bisect bad d4576510090f82fe28ee9ee0a9e299fe2541f06c
# bad: [ccabeba586b621195f3d9342ec2d6391f1d28a82] source sha:e141017c686c4fb1dbd3533dffff396f62f103f7
git bisect bad ccabeba586b621195f3d9342ec2d6391f1d28a82
# bad: [21cd19d9dfd9cecd3c7284201896b6310b88eedd] source sha:0f4ac20e0456b32995f7a3aff4e46b59e64704a6
git bisect bad 21cd19d9dfd9cecd3c7284201896b6310b88eedd
# bad: [60becdeae2c864fde05c98859dc0eb75f975b1df] source sha:36028d9010b697ac97da2acc0fa21610ea8731b0
git bisect bad 60becdeae2c864fde05c98859dc0eb75f975b1df
# good: [bfb802b09c15f8c054b2e1ef48c8d060cb5f9c7b] source sha:ad5323b2aae7a69e58629717fb71618ffb727e8d
git bisect good bfb802b09c15f8c054b2e1ef48c8d060cb5f9c7b
# bad: [32262d627096814a62a9261971440842e662284b] source sha:4bf7614503292fe69d3e5835621c1cdcaa4536cb
git bisect bad 32262d627096814a62a9261971440842e662284b
# good: [02296c76b9649f748ef624ef222001798a1bde5d] source sha:6bf020fb7ef0a13188ece51d41dd101141b42b41
git bisect good 02296c76b9649f748ef624ef222001798a1bde5d
# bad: [6158dc3b35af692504c2f49e945df8059eebf092] source sha:5ffd2c1595d1f67f5e4b14e48188a1f37f1956b5
git bisect bad 6158dc3b35af692504c2f49e945df8059eebf092
# good: [eb1ddc8312557391857724e994afaf319cbf4398] source sha:1d3494b55bc6d89a0ec4ca64a52e354337d937a0
git bisect good eb1ddc8312557391857724e994afaf319cbf4398
# good: [fa680e7001153e622599ea485b61a1a48a0bfa25] source sha:ca6c108caaeca5c8176164fcad70ae7a77865892
git bisect good fa680e7001153e622599ea485b61a1a48a0bfa25
# first bad commit: [6158dc3b35af692504c2f49e945df8059eebf092] source sha:5ffd2c1595d1f67f5e4b14e48188a1f37f1956b5
Comment 3 raal 2016-11-26 10:24:17 UTC
The same commit as in bug 104016. I'm not closing as a duplicate because symptoms are different and we need to verify bullets indention and spacing (bug 104016) and Shadow arrow lost (this bug) after the fix.
Comment 4 Miklos Vajna 2017-02-10 21:49:48 UTC
I see that this is not a problem on master anymore, but it's a problem on libreoffice-5-3-branch-point. daily linux dbgutil bibisect says that the core.git range is when it got fixed is 2db42ab241d0852d89a470b18727c22d0fc06745..4130c8def811d1dcc87eacaa8ae48ba02738a790, from which 787d31a94510ca3de9ce582d7b7402dfca584b23 is the commit that fixed this.

So most probably the bibisect from comment 2 somehow went wrong, and the real problematic commit is 5ffd2c1595d1f67f5e4b14e48188a1f37f1956b5, even if it looked innocent. :-)

Long story short this is a duplicate of bug 104144.

*** This bug has been marked as a duplicate of bug 104144 ***