Bug 104054 - Crash when attempting to modify or create a table style
Summary: Crash when attempting to modify or create a table style
Status: RESOLVED DUPLICATE of bug 101648
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-20 10:10 UTC by Jean-Francois Nifenecker
Modified: 2016-11-20 18:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Francois Nifenecker 2016-11-20 10:10:31 UTC
Using either LibreOffice version: 5.3.0.0.alpha1
Build ID: f4ca1573fcf445164c068c1046ab5d084e1b005f

or
the LibreOffice daily build available here http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@70-TDF/current/master~2016-11-18_23.09.33_LibreOfficeDev_5.3.0.0.alpha1_Linux_x86-64_deb.tar.gz

I'm testing the new table style functionnality.

Every time I try to either modify a stock table style (eg "Blue"), or to create a new (custom) table style, I get the same crash with a dialog stating:
"file:///opt/libreofficedev5.3/program/../share/config/soffice.cfg/modules/swriter/ui/templatedialog32.ui"

Trying to modify an existing table style. Steps to reproduce:
0. Open LibreOffice v.5.3.0 alphaX Writer
1. Go to the Styles and formatting pane and select the table styles
2. Right click on the "Blue" preset table style
3. Select "Change"
You get the crash above.

Trying to create a new table style. Steps to reproduce:
0. Open LibreOffice v.5.3.0 alphaX Writer
1. Go to the Styles and formatting pane and select the table styles
2. Right click the styles list pane
4. Select "New"
You get the same crash as above.
Comment 1 Xisco Faulí 2016-11-20 18:20:50 UTC
Confirmed in

Version: 5.3.0.0.alpha1+
Build ID: 9745d29227e471ce40e9992fefd92e10a48696fb
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout
Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Table styles was added to the sidebar in this commit:

author	Jakub Trzebiatowski <ubap.dev@gmail.com>	2016-07-28 13:33:17 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2016-08-01 14:03:07 (GMT)
commit	e7ea91f283ce9b96db58087d87d81d29bcb727a4 (patch)
tree	5c5f8b1fe17d0eba63d4d180a1b76f02f3e1744a
parent	d1ffaf5315497140dedbc67c78f14706591b314e (diff)
GSoC Writer Table Styles; Table Styles Panel
Table styles panel:
+ Added simple table style panel tab icon.
    icon-themes/galaxy/sw/imglst/sf06.png
+ Listing table styles (hierarchical, same order as in container)
+ Listing all table styles (sorted by name).
+ Listing applied table styles.
+ Listing custom styles.
+ Listing hidden styles.
+ Hide/show style.
+ Applying style by double clicking.
+ Highlight current table style.
Everything else yet to be done.

Table styles (SwTableAutoFormat):
+ "hidden" property.
+ "userDefined" property. "Default style" is not user defined. Styles loaded
from tblauto.fmt are also not user defined. Styles loaded from .odt are user
defined. Styles created manually (before binary load/save roundtrip) are user
defined.

Adding Cc: to Jakub Trzebiatowski
Comment 2 Maxim Monastirsky 2016-11-20 18:24:31 UTC

*** This bug has been marked as a duplicate of bug 101648 ***