Bug Hunting Session
Bug 104055 - Table style modification results in unwanted formatting
Summary: Table style modification results in unwanted formatting
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevAdvice
Depends on:
Blocks: Table-Styles
  Show dependency treegraph
 
Reported: 2016-11-20 10:37 UTC by Jean-Francois Nifenecker
Modified: 2017-03-04 20:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Francois Nifenecker 2016-11-20 10:37:47 UTC
After having modified a preset table style, the new formatting is not consistent.

Steps to reproduce:
0. Open LibreOffice v.5.3.0 alphaX Writer
1. Add a table in the current document (at least three lines)
2. Go to the Styles and formatting pane and select the table styles
3. Double click on the "Blue" preset table style to set the table formatting
4. Select the table header line
5. Go to the Table properties dialog and change the background to some other colour, like Red for instance
5. Go back to the Styles and formatting pane
6. Open the rightmost dropdown toolbutton and select "Update style"
7. Add a new table into the document
8. Set its style to "Blue"
Et voilà. The whole table is set with a Red background, instead of just its heading line.

Everything happens as if all the new table lines formatting was set using the "Blue" table style header parameters (incl. borders).
Comment 1 Buovjaga 2016-11-29 11:13:25 UTC
You have to select all of the table for it to work like you want. No idea, if this is intended.

Win 7 Pro 64-bit Version: 5.4.0.0.alpha0+
Build ID: 142618ecae472e535c582c0fb357d2a9a76655f1
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-11-28_00:46:57
Locale: fi-FI (fi_FI); Calc: group
Comment 2 Heiko Tietze 2017-03-04 20:51:08 UTC
Tested with 5.3 and it works. Create a new 5x5 table, set background color for the first/last row/column, select an existing style (or create a new) and update it.

I'm surprised that this is a workaround for 105933, although the new or modified style is stored only for the current document.

Version: 5.3.0.3
Build ID: 5.3.0-2
CPU Threads: 8; OS Version: Linux 4.9; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: de-DE (en_US.UTF-8); Calc: group