Bug 104146 - wrong help text for printing labels and business cards
Summary: wrong help text for printing labels and business cards
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium trivial
Assignee: Gabor Kelemen
URL:
Whiteboard: target:5.4.0 target:5.3.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-24 16:09 UTC by Gerhard Weydt
Modified: 2016-12-08 15:40 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerhard Weydt 2016-11-24 16:09:46 UTC
The help text for printing labels and business cards:
https://help.libreoffice.org/Common/Creating_and_Printing_Labels_and_Business_Cards
is incomprehensible at its end: the last item (6) should be positioned before item 5. Then the sequence is logical: to create a new document... you have to click on "New document"; then, when you have clicked, you will see the synchronize button; and that is exactly what happens.
The new item 6, by the way, should be rephrased: instead of "as soon as you click..." it should read "as soon as you have clicked..." or even "as soon as the new document is created", because the small dialog only appears with the document (and vanishes when it is closed).
The wrong sequence has been honestly translated into all languages I can judge of.
Comment 1 Thomas Hackert 2016-11-24 17:05:36 UTC
Hello Gerhard, *,
thank you for reporting this bug :) I can confirm it with

OS: Debian Testing AMD64
LO: back to OOo 3.2.0 (OOO320m12 (Build:9483)
(my oldest parallel installed OOo/LO version, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux),
so setting "Status" to "NEW" and "Version" to "Inherited From OOo".
HTH
Thomas.
Comment 2 Thomas Hackert 2016-11-24 17:37:57 UTC
Hello Gerhard, *,
as I got a response from Olivier (see //go.mail-archive.com/5EhSNFLJ0HJpqeBUo2C9j8P0CFI=>) to add #80430 as a blocker and to add my description of my mail to the l10n list, here it is:
<quote>
due to a debate on our discuss@de.l.o list, I found the following:
<quote>
Designing Labels and Business Cards

You can design both labels and business cards through the Labels 
dialog.

1. Choose File - New - Labels to open the Labels dialog.
2. On the Labels tab, under Format, define the label format.
LibreOffice Writer contains many formats of commercially available 
sheets for labels, badges, and business cards. You can also add 
other, user-defined formats.
3. On the Labels tab, under Inscription, you can choose what you 
want written on the labels.
This often involves database fields, so that the labels can be 
printed with varying content, when sending "Form Letters" for 
example. It is also possible to have the same text printed on every 
label.
4. Use the Database and Table list boxes to select the database and 
table from which the data fields are obtained. Click on the arrow 
button to transfer the selected data field into the inscription 
area. Press Enter to insert a line break. You can also enter spaces 
and any other fixed text.
On the Format tab you can define your own label formats, not covered 
by the predefined formats. To do this, select "User" from the Type 
list box. On the Options tab, you can specify whether all labels or 
only certain ones are to be created.
4. On the Options tab page, make sure that the Synchronize contents 
box is selected. If this is selected, a label only has to be entered 
(on the top left label) and edited once.
5.  As soon as you click on New Document, you will see a small 
window with the Synchronize Labels button. Enter the first label. 
When you click on the Synchronize Labels button, the current 
individual label is copied to all the other labels on the sheet.
6. Click on New Document to create a new document with the settings 
you have entered.
</quote>

on 
https://help.libreoffice.org/Common/Creating_and_Printing_Labels_and_Business_Cards

While trying to follow the steps, I (also confirmed by Gerhard in 
the discussion mentioned above), it seems the last two steps are in 
a wrong order.

So, should this not be changed to
<quote>
(steps 1 to 4 as above)
5. Click on New Document to create a new document with the settings 
you have entered.
6. As soon as you click on New Document, you will see a small window 
with the Synchronize Labels button. Enter the first label. When you 
click on the Synchronize Labels button, the current individual label 
is copied to all the other labels on the sheet.
</quote>
?

I have tried to find these in Pootle (e.g. 
https://translations.documentfoundation.org/de/translate/#search=As%20soon%20as%20you%20click%20on%20New%20Document&sfields=source,target 
and found 
https://translations.documentfoundation.org/de/libo50_help/translate/shared/guide.po#unit=94047295 
where it appears without enumeration.
<quote>
HTH
Thomas.
Comment 3 Commit Notification 2016-12-08 14:48:52 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=973fc93ec46a30b6aa57e6f328022ee79958a121

tdf#104146 Switch order of list items
Comment 4 Commit Notification 2016-12-08 15:32:49 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=f97b2c24427e1965802eb799a9fd472e23664183&h=libreoffice-5-3

tdf#104146 Switch order of list items