Bug 104153 - EDITING: Application crash when remove filter from dynamic table
Summary: EDITING: Application crash when remove filter from dynamic table
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.3.3 release
Hardware: All Linux (All)
: high major
Assignee: Caolán McNamara
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.3.1 target:5.2.6
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2016-11-25 05:40 UTC by Tavo
Modified: 2017-01-27 20:49 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Data to reproduce the problem. Edit dynamic table, add filter, accept. Edit again and try to remove the field. (15.65 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-11-25 05:40 UTC, Tavo
Details
bt with debug symbols (5.78 KB, text/plain)
2017-01-25 21:34 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tavo 2016-11-25 05:40:35 UTC
Created attachment 128998 [details]
Data to reproduce the problem. Edit dynamic table, add filter, accept. Edit again and try to remove the field.

With dynamic table created, i try to drag the field from "Campos de pagina" to "Campos disponibles" and application crash.

Version Libreoffice 5.3 Beta 1, spanish (is not present in the list)
Comment 1 Joel Madero 2016-11-25 05:58:34 UTC
Version: 5.4.0.0.alpha0+
Build ID: 8a279d7de4cf94c99f655f6edd0da0c24ab4003c
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: en-US (en_US.UTF-8); Calc: single

Confirmed.

Repro Steps:
Open attached file;
Go to sheet 2;
Right click on filter for pivot table (i.e., cell B4);
Go to "Edit Layout";
Drag "Precio" to "Page Fields: section;
Click Ok;
Right click on A2 ("Precio");
Go to "Edit Layout";
Drag "Precio" out of Page Fields: section to the right

Observed: Crash
Comment 2 thackert 2016-11-25 09:58:41 UTC
Hello Tavo, Joel, *,
I have tested it with

OS: Debian Testing AMD64
LO: Version: 5.3.0.0.beta1
Build-ID: 690f553ecb3efd19143acbf01f3af4e289e94536
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: Standard; VCL: gtk2; Layout-Engine: neu; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group
(parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux)

where this does not lead to a crash when following the instructions from comment 2 by Joel. Would one of you would be so kind to test it again on your system, if this bug is really fixed, please?
TIA
Thomas.
Comment 3 Tavo 2016-11-25 14:42:32 UTC
Kernel version:
Linux debianenvy 4.8.0-1-amd64 #1 SMP Debian 4.8.5-1 (2016-10-28) x86_64 GNU/Linux
CPU Threads: 4;
Locale: en-US (en_US.UTF-8); Calc: single

Hi Thomas
   The problem still present in 5.3 Beta 1.
   I tried 5.3.0.0.alpha1_Linux_x86-64_deb version and the behaviour is the same building the data from zero.
   
Best Regards.
Tavo.
Comment 4 Julien Nabet 2017-01-15 19:47:04 UTC
Would it be possible to have a backtrace following https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace ?
Comment 5 Xisco Faulí 2017-01-25 16:03:18 UTC
it seems to be only happening in GTK3. Adding Caolán McNamara...
Comment 6 Caolán McNamara 2017-01-25 21:07:15 UTC
I don't see it personally in 5-3 or master as of yet.
Comment 7 Julien Nabet 2017-01-25 21:34:48 UTC
Created attachment 130682 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today (+enable-dbgutil), gtk3 I could reproduce this.

Steps to reproduce:
1) Edit layout
2) Drag Marca field from available fields and drop it to page panel, click OK
=> layout is update with page Marca
3) Edit layout (again)
4) Drag Marca field from page panel and drop it to available fields (so to remove it), click OK
=> crash

Remark: it's not specific to gtk3, I could reproduce this with gen and kde4 rendering
Comment 8 Caolán McNamara 2017-01-26 09:06:56 UTC
I can reproduce it with gen and I see it in 5.2.3.3 too
Comment 9 Commit Notification 2017-01-26 09:22:14 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=068edb65b1dce375223d8642a01b07db3948ac03

Resolves: tdf#104153 crash on drag and drop pivot table field

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Caolán McNamara 2017-01-26 11:41:14 UTC
Pivot tables aren't really my thing, but https://gerrit.libreoffice.org/#/c/33575/ seems to work the way I expect it to work. Not sure if it covers everything necessary though.
Comment 11 Commit Notification 2017-01-27 15:34:15 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=011bae55cdd24a1d3e42f0aa2fcfd98d3ddc9b14

Resolves: tdf#104153 lookup what listbox an entry is dragged from

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Caolán McNamara 2017-01-27 15:59:10 UTC
fixed in master, backports for 5-3 and 5-2 in gerrit
Comment 13 Commit Notification 2017-01-27 16:35:55 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=839d9fa764921258abd48336142a1383f95f5808&h=libreoffice-5-3

Resolves: tdf#104153 crash on drag and drop pivot table field

It will be available in 5.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2017-01-27 20:49:46 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a9b7c569652ba27ecda572a0cc8ad7a12143e903&h=libreoffice-5-2

Resolves: tdf#104153 crash on drag and drop pivot table field

It will be available in 5.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.