Bug Hunting Session
Bug 104175 - LibO crashes when adding remote Windows/SMB share
Summary: LibO crashes when adding remote Windows/SMB share
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.2.3.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Network
  Show dependency treegraph
 
Reported: 2016-11-26 00:27 UTC by Michael Shuen
Modified: 2019-03-21 09:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["INetURLObject::decode(rtl::OUStringBuffer const &,INetURLObject::DecodeMechanism,unsigned short)"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Shuen 2016-11-26 00:27:14 UTC
Description:
When starting LibreOffice after a fresh install and attempting to add a Windows network share, the LibreOffice main window disappears and the crash reporter appears.

Steps to Reproduce:
1. Start LibreOffice
2. On left sidebar, click on "Remote Files"
3. Click on "Add Service"
4. Change the "Type" dropdown to "Windows Share"
5. In "Host:", put a computer name, like "COMPUTER1" without http:// or \\ in front. (I used "openwrt".)
6. Put a share name into the "Share" field. (I used "usbdrive".)
7. Put in strings for "User" and "Password".
8. Make sure "Remember Password" is not checked.
9. The "Root" field is left blank.
10. Click OK.
11. Crash.

Actual Results:  
The main LibreOffice window disappears, but the "Remote Files" window remains open. However, I am able to interact with that window besides dragging it by the title bar. A "LibreOffice Document Recovery" screen appears.

Expected Results:
LibreOffice would connect to the network share and list my files.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.0; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Michael Shuen 2016-11-26 00:29:33 UTC
c708f39a-24e9-4502-8f2d-07d4afd712cf
Comment 2 tommy27 2016-11-29 12:51:21 UTC
please tell which LibO version you are using
Comment 3 Michael Shuen 2016-12-01 05:14:02 UTC
(In reply to tommy27 from comment #2)
> please tell which LibO version you are using

Version: 5.2.3.3
Build ID: d54a8868f08a7b39642414cf2c8ef2f228f780cf
Comment 4 Xisco Faulí 2017-01-10 13:10:15 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: 6bd7451ecd66417a4e8b8dff3874c15ba4d1536e
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-05_23:24:16
Locale: es-ES (es_ES); Calc: group
Comment 5 Xisco Faulí 2017-01-10 13:11:56 UTC
I can't reproduce it in

Version: 5.4.0.0.alpha0+
Build ID: 9a30cb2161506e003f14592d83075ab9d30516c1
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

so it might be WIN ONLY
Comment 6 Julien Nabet 2019-02-15 16:34:43 UTC
On Win7, with master sources updated today, I don't have Windows Share option.

What service should I use?
Comment 7 Xisco Faulí 2019-03-21 09:52:18 UTC
I can no longer reproduce it in

Version: 6.3.0.0.alpha0+
Build ID: 7c7a4675ad5d61add70dd073f680ea37012962ce
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

in fact, there are no crashes in versions higher than 6.1.0.3 in https://crashreport.libreoffice.org/stats/signature/INetURLObject::decode(rtl::OUStringBuffer%20const%20&,INetURLObject::DecodeMechanism,unsigned%20short).

Closing as RESOLVED WORKSFORME