Bug Hunting Session
Bug 104188 - irritating disfunction in the table formatting
Summary: irritating disfunction in the table formatting
Status: RESOLVED DUPLICATE of bug 82684
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.3.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.0.1 target:6.2.6
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-26 16:11 UTC by jlbraga
Modified: 2019-06-29 00:47 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
example 1 (35.90 KB, image/png)
2016-12-02 17:07 UTC, jlbraga
Details
example 2 (40.14 KB, image/png)
2016-12-02 17:08 UTC, jlbraga
Details
example 3 (38.52 KB, image/png)
2016-12-02 17:08 UTC, jlbraga
Details
the example in a document form (28.42 KB, application/vnd.oasis.opendocument.text)
2016-12-04 15:40 UTC, jlbraga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jlbraga 2016-11-26 16:11:28 UTC
I have a list of some cell tables. They have cells horizontally and vertically. Some don't stay entirely on one page: they start somewhere near the end of a page, and some cells pass to the next page.

I want to create an outline for each table, but there's a problem.

I only want to select the 4 surrounding lines of the outer limits of each table, but I want the tables that stay in 2 different pages to DON'T get separated by any outlines, as if they were 2 tables. I mean, the last cell near the end of the first page must NOT get the lower outline, and the first cell near the beginning of the next page must NOT get the upper outline. Sometimes, it's just the same cell, but in 2 different pages.

However, some of the tables get just as I want, but some some get all the 4 outlines in BOTH pages!

That's not the order I give to the program...can you do something about it?

Thanks in advance!
Comment 1 jlbraga 2016-11-27 15:44:39 UTC
Now I have another problem: one of the tables occupying 2 different pages gets no lines in the end/beginning of the page, just like I want, BUT the last cell on the 2nd page doesn't get the lower outline. And when you get to the table formatting, you see that it doesn't even marked there. You select the lower line (or the 4 outlines), you press "OK", but it doesn't appear again!
Comment 2 jlbraga 2016-11-28 19:27:03 UTC
Oh, forgot to say: the different tables ares in fact parts of a bigger one single table which constitutes the entire document.
Comment 3 Buovjaga 2016-12-02 08:27:31 UTC
Please attach an example document.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 4 jlbraga 2016-12-02 17:07:47 UTC
Created attachment 129256 [details]
example 1
Comment 5 jlbraga 2016-12-02 17:08:20 UTC
Created attachment 129257 [details]
example 2
Comment 6 jlbraga 2016-12-02 17:08:54 UTC
Created attachment 129258 [details]
example 3
Comment 7 jlbraga 2016-12-02 17:19:46 UTC
Just done it, see the attachments, please.


And, like I said, there's one more case, in which I get the outlines as I want, except the lower one...however, it seems to don't exist anymore, since I changed the outine color, added one more cell, and selected the lower outline manually in the last cell (or the upper one in the next cell, I don't remember). Since then, I select the 4 outlines and they appear as I want.
Comment 8 Buovjaga 2016-12-03 19:26:09 UTC
It would be great, if you could attach an actual document instead of screenshots. I know you have to anonymize it a bit, but there is no hurry.
Comment 9 jlbraga 2016-12-04 15:40:37 UTC
Created attachment 129303 [details]
the example in a document form

There, I've done it, see the attachment, please.
Comment 10 Buovjaga 2016-12-07 14:23:26 UTC
Ok, I finally understood that by "outlines" you actually meant borders. Closing as dupe as I found basically the same report.

*** This bug has been marked as a duplicate of bug 82684 ***
Comment 11 Commit Notification 2019-06-27 13:05:46 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/1cb7e4899b5ada902e99a0c964ee047950c07044%5E%21

sw: avoid deleting the iterated SwRowFrame on tdf104188-4.odt

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2019-06-27 15:05:28 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/92e3eb149c6611aa8b6b3d01e1775c5afc95dec5%5E%21

sw: avoid deleting the iterated SwRowFrame on tdf104188-4.odt

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2019-06-29 00:47:20 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/c5e8780391acb1f9fd72f8956438a79dfa64ca53%5E%21

sw: avoid deleting the iterated SwRowFrame on tdf104188-4.odt

It will be available in 6.2.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.