Bug 104196 - OpenGL: '5' and '7' glyph not rendered correctly with Nvidia hardware
Summary: OpenGL: '5' and '7' glyph not rendered correctly with Nvidia hardware
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: VCL-OpenGL HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2016-11-27 09:08 UTC by Luke
Modified: 2016-12-01 09:27 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the font rendering issue (66.32 KB, image/png)
2016-11-27 09:08 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2016-11-27 09:08:26 UTC
Created attachment 129045 [details]
Screenshot of the font rendering issue

With LO 5.3 and recent builds of 5.4 on my Nvidia GTX 650 under Windows 10, the '5' and '7' are not displaying properly in Calc. 

Steps to reproduce:
1. Start Calc
2. In a cell, enter  '5' or'7'

Actual results:
They look like 'b' and a crooked 'l'.

Turning off "Use OpenGL for all rendering", fixes the issue. 
Changing the font, fixes the issue. 
Using Layout Engine: old on 5.3, fixes the issue.
Changing zoom from 100 to 200, fixes the issue.
Comment 1 V Stuart Foote 2016-11-27 17:51:12 UTC
Confirmed.

On Windows 10 Pro 64-bit (1607) en-US with nVidia GTX-750ti
Version: 5.3.0.0.beta1 (x64)
Build ID: 690f553ecb3efd19143acbf01f3af4e289e94536
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; Layout Engine: new; 
Locale: en-US (en_US); Calc: CL

More DirectWrite OpenGL rendering joy...
Comment 2 V Stuart Foote 2016-11-27 18:02:44 UTC
Of course the default font and settings having this are Liberation Sans at 10pt and 100% zoom.

Also, in addition to clipping tops of 5 and 7 glyphs, the 8 and 9 glyph are clipped on the left edge.
Comment 3 Khaled Hosny 2016-11-27 19:31:31 UTC
Looks like the same issue as bug 104013, overzealous clipping.

*** This bug has been marked as a duplicate of bug 104013 ***
Comment 4 V Stuart Foote 2016-11-27 19:47:15 UTC
Probably--but have to be a little cautious. 

Bug 104013 is for clipping of left edges of first character in a string for menu entries--and those with Segoe UI on Windows 8, 8.1 and 10

Since we can no longer scale the menu UI, we don't know if those would behave the same--but probably...

And both are back to a DirectWrite OpenGL rendering.
Comment 5 Luke 2016-12-01 09:26:11 UTC
This was actually a separate bug. Fixed by:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ba3e52699bc05911bc1f9e3cbd5d1332902c736a
Comment 6 Luke 2016-12-01 09:27:10 UTC
Khaled Hosny committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c7e7a634cf5941fffd97102fe4252aee7445e36b&h=libreoffice-5-3