Bug 104236 - HarfBuzz: Text is shifted to the right
Summary: HarfBuzz: Text is shifted to the right
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2016-11-28 19:41 UTC by Xisco Faulí
Modified: 2016-11-28 21:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (24.50 KB, application/msword)
2016-11-28 19:41 UTC, Xisco Faulí
Details
Comparison LibreOffice 5.2.2 and master (20.18 KB, image/png)
2016-11-28 20:54 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-11-28 19:41:21 UTC
Created attachment 129091 [details]
sample

Steps:
1. Open attached document

Observed behaviour: Text 'Price Quote' is shifted to the right
Expected behaviour: It should be in the center of the square
Comment 1 Khaled Hosny 2016-11-28 20:45:38 UTC
The text is shifted for me on Linux, even with 5.2. I guess this is just expected behaviour from having a new layout engine that applies OpenType features and such. (Alighting things with spaces is always fragile and bad idea in general.)
Comment 2 Xisco Faulí 2016-11-28 20:54:00 UTC
Created attachment 129101 [details]
Comparison LibreOffice 5.2.2 and master
Comment 3 Khaled Hosny 2016-11-28 21:18:05 UTC
(In reply to Xisco Faulí from comment #2)
> Created attachment 129101 [details]
> Comparison LibreOffice 5.2.2 and master

It looks like the top one here even on master. What platform you are testing on?
Comment 4 V Stuart Foote 2016-11-28 21:51:08 UTC
Saving the document from Word 2013 to .ODT, this is just a badly formatted diagram--nothing to do with HarfBuzz layout.

"Price Quote" has 3 tabs and 8 spaces preceding it, while "Item" has 2 tabs and 6 spaces preceding it.

Meaning _any_ hiccup affecting tab stops on filter import and formatting is toast.

When I open in on Windows 8.1 Pro 64-bit en-US with
Version: 5.4.0.0.alpha0+
Build ID: 142618ecae472e535c582c0fb357d2a9a76655f1
CPU Threads: 8; OS Version: Windows 6.29; UI Render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-11-28_00:46:57
Locale: en-US (en_US); Calc: CL

I see the same layout as on your 5.2.2 clip.

While if I open with Version: 5.2.3.3 (x64)
Build ID: d54a8868f08a7b39642414cf2c8ef2f228f780cf
CPU Threads: 8; OS Version: Windows 6.29; UI Render: GL; 
Locale: en-US (en_US); Calc: group

I see them pushed out of the shapes by default tab stops and spaces.