Bug Hunting Session
Bug 104241 - Not possible to scroll past page 1 in GS51-GettingStartedLO.odt (large image on page 1)
Summary: Not possible to scroll past page 1 in GS51-GettingStartedLO.odt (large image ...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-View-Jumps
  Show dependency treegraph
 
Reported: 2016-11-28 22:59 UTC by Aron Budea
Modified: 2019-07-08 01:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2016-11-28 22:59:45 UTC
1. Open this document in Writer: https://wiki.documentfoundation.org/File:GS51-GettingStartedLO.odt
2. Try to slowly scroll down with mousewheel.

Behavior: view jumps back to start of page, impossible to get to next page (with mousewheel).
Note: it's possible to get past the page by scrolling vigorously.

Tested and reproduced with 5.0.0.5, 5.2.3.3, 5.3beta1 / Windows 7.
Tested and not reproduced with 4.4.0.3.
=> regression

Might be Windows-only, needs confirmation in a different OS.
Comment 1 tommy27 2016-11-30 05:22:48 UTC
reproduced under Win8.1 64 using LibO 5.2.3.3

I see that there's a kind of "huge" text cursor blinking in the first page...
looks like the text cursor became so big to fill almost the entire page.
maybe there's some conflitct between scrolling and cursor position.
Comment 2 Jacques Guilleron 2016-11-30 14:31:53 UTC
Hi Aron, Tommy,

First of all, "Read only" mode allows the scroll down instantly.
Else, in "Edit mode", we have to wait around twenty seconnds before to scroll, but after this time scroll down is available.
This seems avoidable by selecting the first image, and setting Wrap to Wrap Through.
After saving, there's no longer cursor, and "scroll down" is available
at once.

Do you confirm it?

Jacques
Comment 3 Aron Budea 2016-11-30 15:00:03 UTC
Hi Jacques, great observations. I an confirm what you wrote, except setting wrap to wrap through, that doesn't help in my case (5.2.3.3).
Comment 4 Aron Budea 2017-01-05 20:38:39 UTC
Reproduced even with 3.3.0 / Ubuntu 16.04. Adjusting version.
Comment 5 QA Administrators 2018-05-25 02:43:28 UTC Comment hidden (obsolete)
Comment 6 Drew Jensen 2018-06-28 14:22:07 UTC
Confirmed that behavior remains when checked with 6.1 Beta2 (Ubuntu 18.04 64bit)
Comment 7 QA Administrators 2019-06-29 02:58:29 UTC Comment hidden (obsolete)
Comment 8 Aron Budea 2019-07-08 01:12:55 UTC
The behavior slightly changed between 6.0.0.3 to 6.1.0.3 (and is still the same in 6.3 beta2): you eventually get to scroll down, the view only jumps back after each first couple of scrolls, but not afterwards. Another visible difference is that in 6.0.0.3 the caret flickers very quickly, and in 6.1.0.3 first it doesn't blink at all, and later blinks normally.

Still, I'd expect scrolling to be visible right away... the situation definitely improved, though.