Download it now!
Bug 104245 - Conditional Formatting not copying correctly
Summary: Conditional Formatting not copying correctly
Status: RESOLVED DUPLICATE of bug 104026
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2016-11-29 00:43 UTC by Mark S. Winston
Modified: 2017-07-17 09:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark S. Winston 2016-11-29 00:43:03 UTC
Conditional Formatting is not copying correctly under some circumstances:

(1) If a conditional format applies to a single cell (e.g., conditionally formatted cell D9, with Cell Range = D9 in the Conditional Format specification window), clicking the "insert row" icon to add Row 10 does NOT result in the Cell Range being changed properly (e.g., to D10 for the cell immediately below D9) -- instead, the Cell Range setting for the newly added cell immediately below is changed to a range (e.g., instead of D10, it is D9:D10).

(2) Using the same example, if I perform the following sequence, I get a different incorrect result for the conditional format's cell range.  Using the previous example:  (a) Click "insert row" icon to add blank Row 10.  (b) Click the row number 9 to select the entire Row 9.  (c) Press Ctrl+C to copy Row 9's contents to clipboard.  (d) Move the cursor to cell A10.  (e) Press Ctrl+V to paste Row 9 contents into blank Row 10.  This sequence results in Row 9's cell formulas being adjusted properly across the new Row 10 -- EXCEPT that conditional formats are NOT adjusted (e.g., the Cell Range of conditionally formatted D10 is still D9, and any cell references within the Conditions formulas in the Conditional Format window are also NOT adjusted).

There are also situations where conditional formatting is not saved properly along with the rest of the spreadsheet, but I think this likely results from the above errors.  I have not yet documented precise sequences to reproduce errors.
 
Hope this helps,
-m.
Comment 1 p_kongstad 2017-01-28 08:39:09 UTC

*** This bug has been marked as a duplicate of bug 104026 ***