Download it now!
Bug 104277 - UX: Difference in behavior between enabling/disabling OpenGL and OpenCL
Summary: UX: Difference in behavior between enabling/disabling OpenGL and OpenCL
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All Windows (All)
: medium enhancement
Assignee: Nickson Thanda
URL:
Whiteboard: target:6.2.0 target:6.3.0
Keywords:
: 114693 121139 (view as bug list)
Depends on:
Blocks: Options-Dialog
  Show dependency treegraph
 
Reported: 2016-11-30 12:38 UTC by Telesto
Modified: 2018-12-12 15:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-11-30 12:38:39 UTC
Description:
When enabling or disabling OpenGL, it's giving a choice between 'Restart Now' or 'Restart Later'. When enabling or disabling OpenCL a information window pops up: 'Please restart LibreOfficeDev now so the new or modified values can take effect'


Steps to Reproduce:
1.Start LO
2.Tools -> Options -> View
3.Enable or disable "Use OpenGL for all rendering" (Dialog A)

4.Go to Tools -> Options -> OpenCL
5.Enable or disable "Allow use of OpenCL" (Dialog B)

Actual Results:  
With OpenGL there is a choice between restart now or not
With OpenCL you have the restart manually 

Expected Results:
When enabling/disabling OpenCL it should also request a restart, in the same way as with OpenGL


Reproducible: Always

User Profile Reset: YES

Additional Info:
Version: 5.4.0.0.alpha0+
Build ID: 4130c8def811d1dcc87eacaa8ae48ba02738a790
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-11-29_01:03:18
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Buovjaga 2016-12-02 08:41:33 UTC
Repro.

Win 7 Pro 64-bit Version: 5.4.0.0.alpha0+
Build ID: 142618ecae472e535c582c0fb357d2a9a76655f1
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-11-28_00:46:57
Locale: fi-FI (fi_FI); Calc: group
Comment 2 Mike Kaganski 2017-12-26 10:16:31 UTC
*** Bug 114693 has been marked as a duplicate of this bug. ***
Comment 3 Telesto 2018-07-17 06:59:00 UTC
See also bug 114693 comment 0 (Mike Kaganski). Quote:
Throughout LibreOffice, changing several options requires restart to take effect. This includes OpenGL/OpenCL use, UI language, and extension installation, among other.

When some of them changes, warnings about restart required are emitted to user; however, the warnings are different for different settings:

* For OpenCL, a dialog with "Please restart LibreOfficeDev now so the new or modified values can take effect." and single OK button is shown, which simply informs about the necessary action, and relies on user doing it at a later time.
* For UI language, OpenGL, and installation of extensions, a "Restart LibreOffice" dialog with "For the <feature name here> to take effect, LibreOffice must be restarted. Do you want to restart LibreOffice now?" and two buttons, "Restart Now" and "Restart Later", is shown, which allows to initiate the restart immediately, or do it manually at a later stage.

The proposal is to unify the OpenCL restart warning (and others using similar warnings) with the one used for UI language etc.
Comment 4 Commit Notification 2018-07-18 15:16:36 UTC
Nickson Thanda committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=84ee78fce5e980d3593fbbbe49005f35c5b3e2d0

tdf#104277 - Added restart buttons to OpenCL restart dialog

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Heiko Tietze 2018-07-19 14:45:15 UTC
As Linux user I cannot ultimately verify the change as I don't get OpenGL. But the OpenCL dialog shows up and works. Nitpick: the dialog can be closed per x on top right, which may confuses users if that means yes or no (now/later). But it works well.
Comment 6 Mike Kaganski 2018-11-03 10:04:57 UTC
*** Bug 121139 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2018-12-12 15:21:52 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/2b6bd096f5bd9d250e4590d7150190086ad282b2%5E%21

tdf#104277 follow-up: use svtools::executeRestartDialog

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.