Bug Hunting Session
Bug 104296 - VIEWING: Relatively slow scrolling in GDI mode if a simple GIF-file is embedded
Summary: VIEWING: Relatively slow scrolling in GDI mode if a simple GIF-file is embedded
Status: RESOLVED DUPLICATE of bug 113038
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, haveBacktrace, perf, regression
Depends on:
Blocks: Writer-Images
  Show dependency treegraph
 
Reported: 2016-11-30 21:39 UTC by Telesto
Modified: 2018-08-14 18:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file containing a gif (11.83 KB, application/vnd.oasis.opendocument.text)
2016-11-30 21:40 UTC, Telesto
Details
Example file containg a jpg (18.73 KB, application/vnd.oasis.opendocument.text)
2016-11-30 21:41 UTC, Telesto
Details
Example file containg a png (12.26 KB, application/vnd.oasis.opendocument.text)
2016-11-30 21:41 UTC, Telesto
Details
Callgrind output from master (6.11 MB, application/x-xz)
2017-06-20 13:15 UTC, Buovjaga
Details
Screencast (615.00 KB, video/x-msvideo)
2017-06-20 14:21 UTC, Telesto
Details
Example file (3.92 MB, application/vnd.oasis.opendocument.text)
2017-11-25 18:20 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-11-30 21:39:11 UTC
Description:
A simple embedded gif file is noticeably slowing down scrolling in GDI mode.

Steps to Reproduce:
1.Open example ODT with GIF file; scroll around
2.Open example ODT with PNG or JPG and scroll around


Actual Results:  
Compared to the embedded jpg/png scrolling with the gif file is quite a bit slower. 

Expected Results:
It should be nearly the same


Reproducible: Always

User Profile Reset: YES

Additional Info:
Version: 5.4.0.0.alpha0+
Build ID: 4130c8def811d1dcc87eacaa8ae48ba02738a790
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-11-29_01:03:18
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2016-11-30 21:40:40 UTC
Created attachment 129169 [details]
Example file containing a gif
Comment 2 Telesto 2016-11-30 21:41:04 UTC
Created attachment 129170 [details]
Example file containg a jpg
Comment 3 Telesto 2016-11-30 21:41:29 UTC
Created attachment 129171 [details]
Example file containg a png
Comment 4 Buovjaga 2016-12-07 17:09:05 UTC
Ok, I do notice the slight choppiness when scrolling in the gif document compared to jpg - also CPU fans revving.

3.6 feels snappy, so let's throw this to the bibisect pile.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 252008d49203344ebe69e727a260a48bc76d7a82
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on December 6th 2016

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.3.3
Build ID: 5.2.3-1
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)

Version: 5.4.0.0.alpha0+
Build ID: babf6d5e53516e80e8e3f2485796ebfaeb20e9c1
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-02_00:57:58
Locale: fi-FI (fi_FI); Calc: group
Comment 5 Xisco Faulí 2017-06-19 21:19:56 UTC
To me, in

Version: 6.0.0.0.alpha0+
Build ID: 08f6f9dded1b142b858c455da03319abac691655
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

GIF and JPG have a similar behaviour
Comment 6 Buovjaga 2017-06-20 13:15:30 UTC
Created attachment 134160 [details]
Callgrind output from master

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: d6c4c576ef71f2294ec8eefc6576a797220e6809
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on June 18th 2017
Comment 7 Telesto 2017-06-20 14:21:52 UTC
Created attachment 134165 [details]
Screencast

35% CPU usage with LibO6.0.0.0 (and still choppy scrolling)
10% CPU with LibO4.1.04 and smooth scrolling

Not found in
Versie: 4.1.0.4 
Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28
Comment 8 Telesto 2017-11-12 18:43:19 UTC
I bisected it on Linux to following commit:

commit 2e5167528f7566dd9b000e50fc1610b7bf99132a
Author:     Armin Le Grand <alg@apache.org>
AuthorDate: Thu Oct 31 14:43:21 2013 +0000
Commit:     Caolán McNamara <caolanm@redhat.com>
CommitDate: Tue Nov 5 15:24:18 2013 +0000
    
Resolves: #i123500# unified Graphic processing to use GraphicPrimitive2D

So the same as: bug 113038
Comment 9 Telesto 2017-11-25 18:20:48 UTC
Created attachment 137986 [details]
Example file

Also happening with 12 megapixel JPG
Comment 10 Telesto 2018-02-14 14:49:12 UTC

*** This bug has been marked as a duplicate of bug 80659 ***
Comment 11 Telesto 2018-08-14 18:06:55 UTC

*** This bug has been marked as a duplicate of bug 113038 ***