Bug 104345 - FILEOPEN DOCX: Paragraphs with top and bottom border, overlapping borders invisible
Summary: FILEOPEN DOCX: Paragraphs with top and bottom border, overlapping borders inv...
Status: RESOLVED DUPLICATE of bug 139948
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Paragraph
  Show dependency treegraph
 
Reported: 2016-12-02 09:45 UTC by Gabor Kelemen (allotropia)
Modified: 2022-04-05 14:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Document with overlapping top and bottom borders (100.81 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-12-02 09:45 UTC, Gabor Kelemen (allotropia)
Details
The document in Word 2013 (93.21 KB, image/png)
2016-12-02 10:14 UTC, Gabor Kelemen (allotropia)
Details
The file in LO master build (204.71 KB, image/png)
2016-12-02 10:55 UTC, Gabor Kelemen (allotropia)
Details
The document in Word 2010 and current 6.2 master (355.95 KB, image/png)
2018-06-26 17:25 UTC, Gabor Kelemen (allotropia)
Details
meghivo_2020_A4_kedv_ERFA.doc: resaved in doc format by MSO2013 (106.00 KB, application/msword)
2018-07-13 10:49 UTC, Justin L
Details
tdf104345_unmergedBorders.odt: export not supported to doc or docx format (15.01 KB, application/vnd.oasis.opendocument.text)
2018-07-13 11:11 UTC, Justin L
Details
tdf104345_docximportEmulation.patch (2.05 KB, patch)
2018-07-13 11:13 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen (allotropia) 2016-12-02 09:45:06 UTC
Created attachment 129231 [details]
Document with overlapping top and bottom borders

Attached file has three paragraphs in the middle with top and bottom borders defined.

The overlapping borders of the middle paragraph are not displayed in a 5.4 master build.
Comment 1 Gabor Kelemen (allotropia) 2016-12-02 10:14:34 UTC
Created attachment 129234 [details]
The document in Word 2013
Comment 2 Gabor Kelemen (allotropia) 2016-12-02 10:55:01 UTC
Created attachment 129239 [details]
The file in LO master build
Comment 3 Telesto 2016-12-02 22:41:05 UTC
Confirming with:
Version: 5.4.0.0.alpha0+
Build ID: 33f5bc54aaa7fe7aa9335726e30f9c349155e04d
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-12-01_23:21:05
Locale: nl-NL (nl_NL); Calc: CL

and with
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL
Comment 4 QA Administrators 2018-06-26 02:45:28 UTC Comment hidden (obsolete)
Comment 5 Gabor Kelemen (allotropia) 2018-06-26 17:25:32 UTC
Created attachment 143141 [details]
The document in Word 2010 and current 6.2 master

Still the same, overlapping border lines are missing.
Comment 6 Justin L 2018-07-13 10:49:51 UTC
Created attachment 143530 [details]
meghivo_2020_A4_kedv_ERFA.doc: resaved in doc format by MSO2013

LO handles .doc import the same way - this comment seems relevant:
// Note #i20672# we can't properly support between lines so best to ignore
// them for now
Comment 7 Justin L 2018-07-13 11:11:42 UTC
Created attachment 143531 [details]
tdf104345_unmergedBorders.odt: export not supported to doc or docx format

Exporting this file into doc/docx formats will show that "between" borders are "thrown away". So, import support should probably wait until someone decides that tackling export emulation is worth the effort.
Comment 8 Justin L 2018-07-13 11:13:25 UTC
Created attachment 143532 [details]
tdf104345_docximportEmulation.patch
Comment 9 QA Administrators 2019-11-08 03:37:53 UTC Comment hidden (obsolete, spam)
Comment 10 Justin L 2021-03-27 11:09:22 UTC
repro 7.2+
Comment 11 Vasily Melenchuk (CIB) 2022-04-05 14:06:15 UTC
Should be fixed in master: fix for tdf#139948 for RTF also affects DOCX.

*** This bug has been marked as a duplicate of bug 139948 ***