Download it now!
Bug 104384 - FILEOPEN DOCX: Textboxes in drawing canvas are corrupted
Summary: FILEOPEN DOCX: Textboxes in drawing canvas are corrupted
Status: RESOLVED DUPLICATE of bug 84399
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX-Textbox DOCX-Frames
  Show dependency treegraph
 
Reported: 2016-12-04 09:51 UTC by Telesto
Modified: 2020-03-04 09:57 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (13.51 KB, application/vnd.ms-word.document.12)
2016-12-04 09:53 UTC, Telesto
Details
Comparison Word Viewer and LO (14.56 KB, application/pdf)
2016-12-04 09:54 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-12-04 09:51:49 UTC
Description:
Textboxes in drawing canvas are converted to one line

Steps to Reproduce:
1.Open attached file

Actual Results:  
5 lines

Expected Results:
5 textboxes


Reproducible: Always

User Profile Reset: YES

Additional Info:
Found in:
Version: 5.4.0.0.alpha0+
Build ID: 33f5bc54aaa7fe7aa9335726e30f9c349155e04d
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-12-01_23:21:05
Locale: nl-NL (nl_NL); Calc: CL

and in:
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2016-12-04 09:53:54 UTC
Created attachment 129292 [details]
Example file
Comment 2 Telesto 2016-12-04 09:54:21 UTC
Created attachment 129293 [details]
Comparison Word Viewer and LO
Comment 3 MM 2016-12-04 12:29:50 UTC
Unconfirmed with v4.2.8.2 under mint 17.3 x64.
Confirmed with v4.3.7.2 under mint 17.3 x64.
Comment 4 QA Administrators 2017-12-08 08:06:23 UTC Comment hidden (obsolete)
Comment 5 Aron Budea 2018-01-15 00:28:21 UTC
Alredy in 4.3.0.4, adjusting earliest version a bit.
Bug still in 6.0.0.1.
Comment 6 Aron Budea 2018-01-15 04:00:29 UTC
Bibisected to the following range, with lots of skipped commits that don't start in between, so I stopped:
https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=d4855da9e9718b31b371376ee8a469e9e26495af..ad51d4952dc30e0d1cdcc6037556cd7c66a61542
Comment 7 Buovjaga 2019-04-14 11:37:41 UTC
With win32-4.3 I got https://gerrit.libreoffice.org/plugins/gitiles/core/+/120e469d176026ceb59abbf74d2ad255323cbc9a
i#115391 better support for MinTextSize settings
... for TextShapes and CustomShapes

Adding Cc: to Armin Le Grand

Same blame as bug 120443 and bug 105693

There is a different problem before the bigger one (box position not harmonious) due to 75934fc178ed90b56d77eb1efebed5bdac8427b6 but maybe it is fixed with 81f9fe3a14f0fc99afbfa7ce3a26a9c7855d0919
Comment 8 Xisco Faulí 2020-03-04 09:57:34 UTC
Issue fixed by https://git.libreoffice.org/core/commit/198685ded79d64b21023ee85e9a15fa1b32705a0
Closing as a duplicate of bug

*** This bug has been marked as a duplicate of bug 84399 ***