Bug 104392 - Data Range menu item isn't shown due to a corrupted ods file
Summary: Data Range menu item isn't shown due to a corrupted ods file
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: Chart-Wizard
  Show dependency treegraph
Reported: 2016-12-04 13:44 UTC by Robert Kraske
Modified: 2017-12-04 12:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

The attached file contains the corrupted ods file, for which the data range menu item disappeared (78.35 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-12-04 13:44 UTC, Robert Kraske

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Kraske 2016-12-04 13:44:53 UTC
Created attachment 129301 [details]
The attached file contains the corrupted ods file, for which the data range menu item disappeared

For any strange reason the content of a chart diagram got lost resp. corrupted.

I entered a new datarange to an existing diagram.
After saving and opening the calc sheet again, the diagram was corrupted.
The new curve (data range 'jahr2011') that I added to the diagram was not available.

I unzipped the calc file ('Test_corrupt.ods') and found the corrupted location
The lost entry is in 'Object 2/content.xml'. There is an empty string in chart:values-cell-range-address of data range 'jahr2011'

          <chart:series chart:style-name="ch11" chart:values-cell-range-address="           " loext:label-string="jahr2011" chart:class="chart:line">
            <chart:data-point chart:repeated="12"/>

Unfortunately this leads to loosing the menu item of Chart Wizard - Data Range. Instead the menu item Chart Wizard - Data Table is shown. 
So I can't fix the corrupted data range in LibreOffice Calc.

When I add the correct data range string into content.xml, save the file, zip it and open the modified file everything works again.

This is the corrected part of content.xml

          <chart:series chart:style-name="ch11" chart:values-cell-range-address="Sheet1.D32:Sheet1.D32 Sheet1.D61:Sheet1.D61 Sheet1.D92:Sheet1.D92 Sheet1.D122:Sheet1.D122 Sheet1.D153:Sheet1.D153 Sheet1.D183:Sheet1.D183 Sheet1.D214:Sheet1.D214 Sheet1.D245:Sheet1.D245 Sheet1.D275:Sheet1.D275 Sheet1.D306:Sheet1.D306 Sheet1.D336:Sheet1.D336 Sheet1.D367:Sheet1.D367" loext:label-string="jahr2011" chart:class="chart:line">
            <chart:data-point chart:repeated="12"/>
Comment 1 m_a_riosv 2016-12-04 15:00:01 UTC
Please how the second graph with table data was created?, If it was pasted from other file the data ranges are change for their values.
Comment 2 Robert Kraske 2016-12-04 18:02:45 UTC
The second graph/diagram was created after I entered the data for Jahr 2014, 2015 and 2016.
There was never any import of data from outside. All data was entered within this file and this sheet.
After entering the datas for Jahr 2013 I did an edit of the graph and added the new graph via the Chart Wizard. I made a copy of the available values cell range
(sorry. I don't know how the wording is in English, as I run a German language version). I changed the according cell range string to use column D.
This worked so far till the new curve for jahr2011.
After closing the chart wizard, the graph showed the correct values.
I closed the ods file. Made a backup copy and opened the ods file again.
Now the graph showed a jahr2011 curve with all values 0, and the chart wizard menu item 'data range' didn't show up, only the 'data table' menu item.

Manually fixing the cell range within the content.xml file did the trick.

We have of course two issues here. 
- Why was the cell range string lost. (Don't know how to reproduce this)
- And why is the 'data range' menu item not shown if the cell range string is lost (this is reproduceable as you can open the file)
Comment 3 Buovjaga 2016-12-18 19:44:15 UTC
If I go to Insert - Chart, the wizard shows Data Range. Are my reproduction steps correct?

Arch Linux 64-bit, KDE Plasma 5
Build ID: db9aec4520766c87a09d4cb0238ed06ebaeaaeeb
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on December 18th 2016
Comment 4 Yousuf Philips (jay) (retired) 2017-04-21 14:39:06 UTC
Hi Robert,

Please respond to Buovjaga's comment.
Comment 5 QA Administrators 2017-10-30 10:54:34 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2017-12-04 12:39:35 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team