Bug 104439 - FILESAVE DOCX: File corrupted after saving as DOCX
Summary: FILESAVE DOCX: File corrupted after saving as DOCX
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-06 15:20 UTC by Telesto
Modified: 2016-12-07 18:02 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (244.88 KB, application/vnd.oasis.opendocument.text)
2016-12-06 15:21 UTC, Telesto
Details
Resulting DOCX export (1.89 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-12-06 19:23 UTC, Telesto
Details
Exported file in MS Word Viewer (110.08 KB, image/png)
2016-12-07 15:52 UTC, Telesto
Details
Exported file in LO (101.39 KB, image/png)
2016-12-07 15:53 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-12-06 15:20:40 UTC
Description:
File corrupted after roundtrip

Steps to Reproduce:
1.Open attachment
2.Save as docx
3.Open the new document in LibreOffice/ MSOffice

Actual Results:  
Corrupted file after roundtrip

Expected Results:
No corrupt file


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 5.4.0.0.alpha0+
Build ID: 33f5bc54aaa7fe7aa9335726e30f9c349155e04d
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-12-01_23:21:05
Locale: nl-NL (nl_NL); Calc: CL

and in:

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2016-12-06 15:21:31 UTC
Created attachment 129351 [details]
Example file
Comment 2 Xisco Faulí 2016-12-06 15:48:21 UTC
I can't reproduce it in

Version: 5.4.0.0.alpha0+
Build ID: 18b3138a7ac4da823e41640bed8a4707029b8fb0
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but I can with

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

Probably fixed by a5cc8993dceb61c63caf26ae995d9d62905291e5

Could you please check with a recent daily build it double check it?
Comment 3 Xisco Faulí 2016-12-06 15:51:43 UTC
Hi Telesto,
I've just added a comment here using ninja-edit so you didn't get any notification. Please check comment 2
Comment 4 Telesto 2016-12-06 19:20:18 UTC
Also reproducible with:
Version: 5.4.0.0.alpha0+
Build ID: a9f56091b6422ec8c42f09b8472200ae4ab12548
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-05_23:12:26
Locale: nl-NL (nl_NL); Calc: CL
Comment 5 Telesto 2016-12-06 19:23:07 UTC
Created attachment 129356 [details]
Resulting DOCX export
Comment 6 Xisco Faulí 2016-12-07 15:29:01 UTC
Hello Telesto,
Which version of MSO Word are you using?
I can open the resulting DOCX document in Word 2010 correctly.
Comment 7 Telesto 2016-12-07 15:49:35 UTC
(In reply to Xisco Faulí from comment #6)
> Hello Telesto,
> Which version of MSO Word are you using?
> I can open the resulting DOCX document in Word 2010 correctly.

MS Word Viewer with Microsoft Open XML Converter, but the DOCX isn't correct in LibO either: 
Version: 5.4.0.0.alpha0+
Build ID: a9f56091b6422ec8c42f09b8472200ae4ab12548
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-05_23:12:26
Locale: nl-NL (nl_NL); Calc: CL
Comment 8 Telesto 2016-12-07 15:52:47 UTC
Created attachment 129374 [details]
Exported file in MS Word Viewer
Comment 9 Telesto 2016-12-07 15:53:29 UTC
Created attachment 129375 [details]
Exported file in LO
Comment 10 Xisco Faulí 2016-12-07 15:57:54 UTC
Hello Telesto,
then, the document isn't corrupted, it just looses the lines. Summary is incorrect, it should be updated.
Could it be a duplicate of bug 104203 ?
Comment 11 Telesto 2016-12-07 18:02:59 UTC
I create new one. I'm quite sure it isn't bug 104203.