Bug Hunting Session
Bug 104474 - Cell graphics rendering glitches with Freezing Rows/Columns or Split Windows
Summary: Cell graphics rendering glitches with Freezing Rows/Columns or Split Windows
Status: RESOLVED DUPLICATE of bug 100925
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.3.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cell-Freeze
  Show dependency treegraph
 
Reported: 2016-12-07 17:02 UTC by benibex
Modified: 2017-07-18 16:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Document that reproduces the problem (19.66 KB, application/vnd.oasis.opendocument.spreadsheet-flat-xml)
2016-12-07 17:02 UTC, benibex
Details

Note You need to log in before you can comment on or make changes to this bug.
Description benibex 2016-12-07 17:02:03 UTC
Description:
When there are frozen rows/columns or split windows enabled, the contents of cells outside the frozen area or "top" split window exhibit graphical glitches. In particular, the old contents of a cell are not "cleared away" when writing new contents. The new contents appear on top of the old contents creating a graphical mess. The underlying, actual value of the cell IS changed, however. The graphical glitch goes away when you leave the cell (e.g., after pressing "Enter")

Steps to Reproduce:
1. Open a new Calc document
2. Freeze the first row
3. Type "123" into cell A2, but do NOT press 'Enter' or leave the cell
4. Press 'Delete' three times to attempt to erase the "123" (again, do not leave the cell or press 'Enter')
5. Type "456"

Actual Results:  
When pressing 'Delete' in step 4, the "123" do not graphically disappear (although the data contents of the cell ARE updated). When typing "456" in step 5, the "456" appears on top of the previous "123" creating a jumbled graphical mess (but note, again, the actual VALUE of the cell is properly updated).

Expected Results:
Whatever is being typed, the current updated contents of the cell are displayed with no graphical irregularities.



Reproducible: Always

User Profile Reset: Yes

Additional Info:
Additional Hardware/Software Info:
- CPU: Intel i7 Broadwell (5th generation)
- Graphics: Intel i965 graphics
- OS: Gentoo Linux
- Relevant drivers: xf86-video-intel
- Settings: OpenGL disabled, hardware acceleration disabled

Further Notes:
- The issue may be specific to Intel graphics hardware and drivers
- The issue may be the same as that reported in Bug #100925 ???

Attachment Notes
- See the attachment for a very basic document that reproduces the problem.
- Document is saved as a flat ods
- The problem goes away entirely if you delete the XML nodes listed below

<config:config-item config:name="HorizontalSplitMode" config:type="short">0</config:config-item>

<config:config-item config:name="VerticalSplitMode" config:type="short">2</config:config-item>

<config:config-item config:name="HorizontalSplitPosition" config:type="int">0</config:config-item>

<config:config-item config:name="VerticalSplitPosition" config:type="int">1</config:config-item>

<config:config-item config:name="ActiveSplitRange" config:type="short">2</config:config-item>

<config:config-item config:name="PositionLeft" config:type="int">0</config:config-item>

<config:config-item config:name="PositionRight" config:type="int">0</config:config-item>

<config:config-item config:name="PositionTop" config:type="int">0</config:config-item>

<config:config-item config:name="PositionBottom" config:type="int">1</config:config-item>


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 benibex 2016-12-07 17:02:54 UTC
Created attachment 129377 [details]
Document that reproduces the problem
Comment 2 m.a.riosv 2016-12-08 23:39:33 UTC
Please test disabling OpenGL
Menu/Tools/Options/LibreOffice/View
Comment 3 benibex 2016-12-09 02:06:58 UTC
All options under Menu/Tools/Options/LibreOffice/View/Graphics Output have been unchecked/disabled and the problem persists. I've tried turning them on and the problem also persists.
Comment 4 QA Administrators 2017-06-28 12:36:14 UTC Comment hidden (obsolete)
Comment 5 benibex 2017-07-03 12:37:50 UTC
Updated long ago and forgot to change the status.
Comment 6 Buovjaga 2017-07-18 16:42:14 UTC
Yes, I can reproduce this and I think it is exactly the same as 100925

*** This bug has been marked as a duplicate of bug 100925 ***