Bug 104481 - Writer crash when the wrap condition for an image is edited (gtk2 only)
Summary: Writer crash when the wrap condition for an image is edited (gtk2 only)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.beta1
Hardware: x86-64 (AMD64) Linux (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2016-12-08 00:52 UTC by Ismael Cedillo
Modified: 2016-12-23 11:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
video with the problem in action (4.27 MB, video/mp4)
2016-12-08 00:52 UTC, Ismael Cedillo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ismael Cedillo 2016-12-08 00:52:09 UTC
Created attachment 129383 [details]
video with the problem in action

In a Writer document, with an image pre-existing or a new image inserted, when is edited the wrap condition (right click->Wrap->an option) for that image, shows an error (without a description) and close immediatly... 

the Libreoffice data is
Version: 5.3.0.0.beta1+
Build ID: 9218c5decc2d8a883d56a8fd657eac27e796b764
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; VCL: gtk2; Layout Engine: new; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-5-3, Time: 2016-12-07_14:35:14
Locale: es-MX (en_US.UTF-8); Calc: group
Comment 1 Julien Nabet 2016-12-10 14:43:54 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
It seems gtk2 only. Indeed, I don't reproduce this with gtk3

I don't know how to retrieve a bt here since there's no segfault.
Comment 2 Buovjaga 2016-12-11 17:25:35 UTC
No repro with gtk2.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 1fce5b024e9f25c3fcef2537a22474ece0dc416f
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on December 10th 2016
Comment 3 Julien Nabet 2016-12-14 22:14:59 UTC
On pc Debian x86-64 with master sources updated today, I still reproduce this

When error popup displayed, I just breaked on gdb and had this bt:
(gdb) bt
#0  0x00002aaaab3c256d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00002aaaacc599f6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00002aaaacc59d82 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00002aaac6feee83 in gtk_dialog_run () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#4  0x00002aaac6c6faf9 in GtkSalSystem::ShowNativeDialog (this=<optimized out>, rTitle=..., rMessage=..., rButtonNames=std::__debug::list = {...}, nDefaultButton=0)
    at /home/julien/lo/libreoffice/vcl/unx/gtk/gtksys.cxx:290
#5  0x00002aaab4a0c5bf in SalGenericSystem::ShowNativeMessageBox (this=0x5555574226e0, rTitle="LibreOfficeDev 5.4 - Fatal Error", rMessage="")
    at /home/julien/lo/libreoffice/vcl/unx/generic/app/gensys.cxx:103
#6  0x00002aaab4923a54 in Application::ShowNativeErrorBox (sTitle="LibreOfficeDev 5.4 - Fatal Error", sMessage="") at /home/julien/lo/libreoffice/vcl/source/app/svapp.cxx:1661
#7  0x00002aaaaafa4bfe in desktop::(anonymous namespace)::FatalError (sMessage="") at /home/julien/lo/libreoffice/desktop/source/app/app.cxx:447
#8  0x00002aaaaafad13c in desktop::Desktop::Main (this=<optimized out>) at /home/julien/lo/libreoffice/desktop/source/app/app.cxx:1699
#9  0x00002aaab492ca21 in ImplSVMain () at /home/julien/lo/libreoffice/vcl/source/app/svmain.cxx:185
#10 0x00002aaab492caef in SVMain () at /home/julien/lo/libreoffice/vcl/source/app/svmain.cxx:223
#11 0x00002aaaaafe1504 in soffice_main () at /home/julien/lo/libreoffice/desktop/source/app/sofficemain.cxx:166
#12 0x00005555555549f9 in sal_main () at /home/julien/lo/libreoffice/desktop/source/app/main.c:48
#13 0x0000555555554a47 in main (argc=<optimized out>, argv=<optimized out>) at /home/julien/lo/libreoffice/desktop/source/app/main.c:47
Comment 4 Michael Meeks 2016-12-21 11:48:07 UTC
Ah - the trace looks like one for an un-caught exception I'm afraid - unfortunately an exception with no message, location or anysuch: hmm =) nasty. We'd need to run under gdb and put a break-point in __cxa_throw before doing the operation to get a good trace =)
Comment 5 Michael Meeks 2016-12-21 14:43:45 UTC
Could be related to the fix for bug#104488 - worth checking perhaps =)
Comment 6 Xisco Faulí 2016-12-22 15:23:36 UTC
Probably a duplicate of bug 104687 ?
Can someone try it in a build with https://cgit.freedesktop.org/libreoffice/core/commit/?id=88dad8fe1a94055dcbb05a6e6f0df2d007914a45 included?
Comment 7 Julien Nabet 2016-12-23 08:58:59 UTC
(In reply to Xisco Faulí from comment #6)
> Probably a duplicate of bug 104687 ?
> Can someone try it in a build with
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=88dad8fe1a94055dcbb05a6e6f0df2d007914a45 included?

I don't reproduce the crash with this patch. Let's put this one to FIXED then.

Ismael/Xisco/Buovjaga: don't hesitate to reopen this tracker if you still reproduce the crash.
Comment 8 Xisco Faulí 2016-12-23 11:25:27 UTC
I can no longer reproduce it in

Version: 5.4.0.0.alpha0+
Build ID: 7a1add76d542e9929c1feab9e06949990e236616
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 9 Julien Nabet 2016-12-23 11:31:15 UTC
(In reply to Xisco Faulí from comment #8)
> I can no longer reproduce it in
> 
> Version: 5.4.0.0.alpha0+
> Build ID: 7a1add76d542e9929c1feab9e06949990e236616
> CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
> Locale: ca-ES (ca_ES.UTF-8); Calc: group

Just to be sure Xisco, you gave a try with gtk2? (I read VCL: gtk3 on your comment)
Comment 10 Xisco Faulí 2016-12-23 11:34:08 UTC
(In reply to Julien Nabet from comment #9)
> (In reply to Xisco Faulí from comment #8)
> > I can no longer reproduce it in
> > 
> > Version: 5.4.0.0.alpha0+
> > Build ID: 7a1add76d542e9929c1feab9e06949990e236616
> > CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
> > Locale: ca-ES (ca_ES.UTF-8); Calc: group
> 
> Just to be sure Xisco, you gave a try with gtk2? (I read VCL: gtk3 on your
> comment)

You're right!!!
Verified in

Version: 5.4.0.0.alpha0+
Build ID: 7a1add76d542e9929c1feab9e06949990e236616
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group