Bug 104539 - File with textbox saved as docx cannot be open in MSO
Summary: File with textbox saved as docx cannot be open in MSO
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All Windows (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:5.4.0 target:5.2.5 target:5.3.0.2
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX-Textbox
  Show dependency treegraph
 
Reported: 2016-12-09 19:37 UTC by Timur
Modified: 2017-01-01 17:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2016-12-09 19:37:07 UTC
Description:
File didn't look good when saved as docx before 5.0, it didn't have a shadow.
From 5.0 it looks OK when saved and reopened in LO, but it can't be open in MSO 2010.

Steps to Reproduce:
1. Open ODT attachment 116374 [details] from Bug 91939
2. Save as DOCX
3. Open in MSO

Actual Results:  
Unspecified error

Expected Results:
Open


Reproducible: Always

User Profile Reset: -

Additional Info:
When confirmed, please set bibisectRequest. 


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Comment 1 Timur 2016-12-09 19:48:31 UTC
ErrorNodeType: OuterShadow
Description: The attribute 'dir' has invalid value. The MinInclusive constraint failed.
Comment 2 Telesto 2016-12-09 23:31:37 UTC
I'm able to open the exported DOCX with Word Viewer (and Microsoft Open XML Converter), but it isn't looking great. It looks OK when opening with LibO

Version: 5.4.0.0.alpha0+
Build ID: a9f56091b6422ec8c42f09b8472200ae4ab12548
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-05_23:12:26
Locale: nl-NL (nl_NL); Calc: CL
Comment 3 steve -_- 2016-12-10 09:41:47 UTC
For me LO master instantly crashes when opening test file. I do not get any crashlog but the recovery dialog called "LibreOfficeDev 5.4 Document Recovery". Due to an unexpected error, LibreOfficeDev crashed.

Version: 5.4.0.0.alpha0+
Build ID: b52167df08511239c3d08904a3d12a3c92141f38
CPU Threads: 8; OS Version: Mac OS X 10.12.1; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-12-09_23:41:33
Locale: de-DE (de_DE.UTF-8); Calc: group

With telesto confirming layout issues and myself running into a LO crash upon opening test file setting this to new, despite the fact that both observations do not match the bugs title. But since LO crashen on opening the file I can even get to the repro point which is needed to confirm this bug here.
Comment 4 Timur 2016-12-12 10:00:44 UTC
This bug is "DOCX cannot be open in MSO" only, so I revert to Unconfirmed. I don't know why you can't reproduce, open fails both with MSO 2010 and 2013 for me. Tested with LO from 5.0 to 5.4+. Works for LO 4.4. (doesn't look fine). I restrict to Windows.

"looking great in MSO" may be another issue, probably after this one is resolved. 

@steve: "LO master crashes" could be another issue, maybe MacOS specific? Please try with some final 5.2+ version, does it produce Crash Report? Master doesn't have this.
Comment 5 Xisco Faulí 2016-12-12 10:27:48 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: 634589b340316ba64b731b4d923c1056be415494
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

but not in

Version: 4.5.0.0.alpha0+
Build ID: 2851ce5afd0f37764cbbc2c2a9a63c7adc844311
Locale: ca_ES
Comment 6 raal 2016-12-27 21:23:16 UTC
This seems to have begun at the below commit.
Adding Cc: to Andras Timar; Could you possibly take a look at this one? Thanks


8153ae3ce07e68b4f601e2a8b72dcc2548ed86b6 is the first bad commit
commit 8153ae3ce07e68b4f601e2a8b72dcc2548ed86b6
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Mon May 25 10:21:57 2015 -0500

    source sha:b848e32dfd5fc6ed4e487e68460d49643fd5e3c1
author	Andras Timar <andras.timar@collabora.com>	2015-02-24 20:34:12 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2015-02-25 13:25:30 (GMT)
commit	b848e32dfd5fc6ed4e487e68460d49643fd5e3c1 (patch)
tree	70f92d1c34ba00921886ec6838e1ea1c535f2f48
parent	c91bfb9ac7d110c5dca0ea34ec0e1668a985b34c (diff)
bnc#637947 export shape shadow to DrawingML
Comment 7 Commit Notification 2016-12-28 13:03:58 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=54d07bdc22067cead094b994491e5c57e1591d76

tdf#104539 dir attribute of outerShdw has to be non-negative

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Timur 2016-12-29 08:13:25 UTC
Thank you. Please always comment on backport, whether submitted or will not be.
Comment 9 Andras Timar 2016-12-29 08:34:20 UTC
I backported the fix to 5-2 and 5-3. Review pending.
Comment 10 Commit Notification 2017-01-01 17:43:19 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7f94dfc93cdade37f371d0c583ff6e9b082737dc&h=libreoffice-5-2

tdf#104539 dir attribute of outerShdw has to be non-negative

It will be available in 5.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2017-01-01 17:47:30 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c6f34422a444cb8be3ac522424a15b3223e161ff&h=libreoffice-5-3

tdf#104539 dir attribute of outerShdw has to be non-negative

It will be available in 5.3.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.