Download it now!
Bug 104549 - Tabbing through Notebookbar and hitting Enter crashes LO after error message "Given module is not a frame nor a window, controller or model."
Summary: Tabbing through Notebookbar and hitting Enter crashes LO after error message ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.0.beta1
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: Notebookbar-Tabbed
  Show dependency treegraph
 
Reported: 2016-12-10 12:04 UTC by Thomas Hackert
Modified: 2018-12-09 00:04 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
"soffice --backtrace" output (15.58 KB, text/plain)
2016-12-10 12:04 UTC, Thomas Hackert
Details
bzip2'ed "soffice --strace" output (608.48 KB, application/x-bzip)
2016-12-10 12:05 UTC, Thomas Hackert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Hackert 2016-12-10 12:04:05 UTC
Hello @ll,
I hope, I have chosen the right component, module, priority and such. If not, feel free to change it adequately ... ;)

While trying to reproduce #102771, I stumbled upon the following:

1. Start Writer
2. Change "View - Toolbar Layout - Notebookbar"
3. Click on the left button in the Notebookbar and choose "Menubar" (though not sure, if this is really needed).
4. Open an ODT file
5. Open another one by clicking on "File - Open" in the Notebookbar
6. Press <Ctrl>+<W> to close the second one

You will see, that "Open" in the Notebookbar is selected.

7. Use the right arrow key.

You will see, that it only moves up to "Open Remote"

8. Press Enter

You will get an error message from LO with

<quote>
Given module is not a frame nor a window,  controller or model.
</quote>

9. Hit Enter

You will see that LO does not respond any longer.

10. Press <Alt>+<F4> a couple of times.

You will see a message like

<quote>
This window might be busy and is not responding.
Do you want to terminate the application?
</quote>
with the text "LibreOfficeDev 5.3 - Fatal Error"

... :( I will attach a gdb as well as a strace log afterwards ... ;)
HTH
Thomas.
Comment 1 Thomas Hackert 2016-12-10 12:04:50 UTC
Created attachment 129454 [details]
"soffice --backtrace" output
Comment 2 Thomas Hackert 2016-12-10 12:05:24 UTC
Created attachment 129455 [details]
bzip2'ed "soffice --strace" output
Comment 3 Buovjaga 2016-12-10 12:50:10 UTC
No problem with master or beta1.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: a564821eb9e991774195120e6965b2a8b1419dc5
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on December 9th 2016

Version: 5.3.0.0.beta1
Build ID: 690f553ecb3efd19143acbf01f3af4e289e94536
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Comment 4 Thomas Hackert 2016-12-11 09:47:30 UTC
(In reply to Buovjaga from comment #3)
> No problem with master or beta1.

thanks for trying to reproduce it :)

> Arch Linux 64-bit, KDE Plasma 5
> Version: 5.4.0.0.alpha0+
> Build ID: a564821eb9e991774195120e6965b2a8b1419dc5
> CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
> Locale: fi-FI (fi_FI.UTF-8); Calc: group
> Built on December 9th 2016
> 
> Version: 5.3.0.0.beta1
> Build ID: 690f553ecb3efd19143acbf01f3af4e289e94536
> CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; Layout
> Engine: new; 
> Locale: fi-FI (fi_FI.UTF-8); Calc: group

Would you be so kind to retest it with the different "SAL_USE_VCLPLUGIN=" options, please? Does it change anything?
TIA
Thomas.
Comment 5 Buovjaga 2016-12-11 09:59:47 UTC
(In reply to thackert from comment #4)
> Would you be so kind to retest it with the different "SAL_USE_VCLPLUGIN="
> options, please? Does it change anything?

Ok, so which option exactly is causing the crash for you?
Gtk3 doesn't focus in the tabs.
Gtk and gen do not cause a crash.

Does Open remote cause a crash for you even in a non-notebookbar interface?

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 1fce5b024e9f25c3fcef2537a22474ece0dc416f
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on December 10th 2016
Comment 6 Thomas Hackert 2016-12-11 10:56:36 UTC
Hello Buovjaga, *,
(In reply to Buovjaga from comment #5)
> (In reply to thackert from comment #4)
> > Would you be so kind to retest it with the different "SAL_USE_VCLPLUGIN="
> > options, please? Does it change anything?
> 
> Ok, so which option exactly is causing the crash for you?
> Gtk3 doesn't focus in the tabs.
> Gtk and gen do not cause a crash.

I am using XFCE4 on Debian, so IIRC it should be GTK2. Or am I wrong here?

> Does Open remote cause a crash for you even in a non-notebookbar interface?

Nope, neither from "File - Open Remote File..." nor clicking on the arrow right of the Open icon and choosing it there.

> Arch Linux 64-bit, KDE Plasma 5
> Version: 5.4.0.0.alpha0+
> Build ID: 1fce5b024e9f25c3fcef2537a22474ece0dc416f
> CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
> Locale: fi-FI (fi_FI.UTF-8); Calc: group
> Built on December 10th 2016

OS: Debian Testing AMD64
DE: XFCE 4.12.3
LO:Version: 5.3.0.0.beta1+
Build ID: 1093721a260d25f986fd794acd914b8fb7bcf92a
CPU Threads: 4; OS Version: Linux 4.5; UI Render: default; VCL: gtk2; Layout Engine: new; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-5-3, Time: 2016-12-10_03:55:11
Locale: de-DE (de_DE.UTF-8); Calc: group
Have a nice day
Thomas.
Comment 7 Julien Nabet 2016-12-29 12:28:00 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce the crash.
Following https://cgit.freedesktop.org/libreoffice/core/commit/?id=88dad8fe1a94055dcbb05a6e6f0df2d007914a45, would it be possible you give a new try with a even recent LO version.
Comment 8 Thomas Hackert 2017-01-01 16:57:30 UTC
Hello Julien, *,
a happy new year to you and thanks for your interest in my bug :)

And sorry for the late reply, but did not find the time to retest it earlier ... :(

(In reply to Julien Nabet from comment #7)
> On pc Debian x86-64 with master sources updated today, I don't reproduce the
> crash.
> Following
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=88dad8fe1a94055dcbb05a6e6f0df2d007914a45, would it be possible you give
> a new try with a even recent LO version.

On my system

OS: Debian Testing AMD64
LO: Version: 5.4.0.0.alpha0+
Build-ID: d3c44886c56f401cc18c2ba480131a621d06c781
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: Standard; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-01-01_10:38:58
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group
(parallel installed following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux)

it is still reproducible ... :(
Have a nice evening
Thomas.
Comment 9 Xisco Faulí 2017-01-02 22:45:35 UTC
I can't reproduce it in

Version: 5.4.0.0.alpha0+
Build ID: 767ec2f138d824b6b51eef73ac9b7d2b193a1e98
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 10 Xisco Faulí 2017-01-12 17:35:03 UTC
Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongsidethe standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 11 Thomas Hackert 2017-01-13 10:30:54 UTC
Hello Xisco, *,
(In reply to Xisco Faulí from comment #10)
> Could you please try to reproduce it with a master build from
> http://dev-builds.libreoffice.org/daily/master/ ?
> You can install it alongsidethe standard version.
> I have set the bug's status to 'NEEDINFO'. Please change it back to
> 'UNCONFIRMED' if the bug is still present in the master build

still reproducible with

OS: Debian Testing AMD64
LO: Version: 5.4.0.0.alpha0+
Build-ID: db4badfc971b9cc60809c3408f579bae04a77c34
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: Standard; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-01-11_00:18:42
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

Have a nice day
Thomas.
Comment 12 Yousuf Philips (jay) (retired) 2017-05-27 12:43:42 UTC
@Thomas: Can you confirm that it still happens with the latest master?

@Maxim, @Szymon: Can you have a peek at the backtrace to see what the problem is?
Comment 13 Thomas Hackert 2017-05-27 13:54:33 UTC
Hello Jay, *,
(In reply to Yousuf Philips (jay) from comment #12)
> @Thomas: Can you confirm that it still happens with the latest master?

still reproducible with
OS: Debian Testing AMD64
LO: Version: 5.5.0.0.alpha0+
Build-ID: 5c16d16ed3db32f922b2aeaad49592d2615c7e2c
CPU-Threads: 4; Betriebssystem:Linux 4.5; UI-Render: Standard; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-05-26_23:00:41
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

... :(
HTH
Thomas.
Comment 14 QA Administrators 2018-05-28 02:31:44 UTC Comment hidden (obsolete)
Comment 15 andreas_k 2018-10-24 13:32:06 UTC
sorry but I can't reproduce this bug in 6.2