Bug 104601 - FILESAVE DOCX: Rotated syringe drawing in Writer after RT
Summary: FILESAVE DOCX: Rotated syringe drawing in Writer after RT
Status: RESOLVED DUPLICATE of bug 122717
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
: 104603 (view as bug list)
Depends on:
Blocks: Shape-ODF-OOXML-export
  Show dependency treegraph
 
Reported: 2016-12-12 11:39 UTC by Telesto
Modified: 2021-05-10 08:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (13.01 KB, application/vnd.oasis.opendocument.text)
2016-12-12 11:40 UTC, Telesto
Details
Position and size settings in original ODT and exported DOCX (90.13 KB, image/png)
2020-09-02 09:44 UTC, NISZ LibreOffice Team
Details
Rotation settings of the original and exported file (84.12 KB, image/png)
2020-09-02 09:46 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-12-12 11:39:51 UTC
Description:
Drawing is broken in Word. 

Steps to Reproduce:
1.Open attached file
2.Save as DOCX Word 2007-2013 XML
3.Open File in Word

Actual Results:  
Drawing is broken in Word (but fine in LibO when opened with the same version)

Expected Results:
Drawing should be OK in Word as LibO


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.4.0.0.alpha0+
Build ID: 84f2ff67a7e404febf710b1dc7f66d06745c503f
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-09_23:20:01
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2016-12-12 11:40:21 UTC
Created attachment 129521 [details]
Example file
Comment 2 Xisco Faulí 2016-12-12 17:07:47 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: 634589b340316ba64b731b4d923c1056be415494
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

Version: 4.3.0.0.alpha0+
Build ID: 52cc0c8f05d40db6d076c13f8b8d6d9453ec8930
Comment 3 QA Administrators 2018-05-08 02:32:18 UTC Comment hidden (obsolete)
Comment 4 NISZ LibreOffice Team 2020-09-02 09:44:50 UTC
Created attachment 165011 [details]
Position and size settings in original ODT and exported DOCX

Multiple grouped shapes with rotation and whatnot...
Lots of settings get bad values here.

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 4c20bb789c7536f63a6844a4cb4489a18cee53c7
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: CL
Comment 5 NISZ LibreOffice Team 2020-09-02 09:46:29 UTC
Created attachment 165012 [details]
Rotation settings of the original and exported file
Comment 6 Timur 2021-03-19 15:33:17 UTC
Could you avoid useless word "broken". It's better in 7.2+.Let's focus on rotation, which is good in Mso and wrong in Lo.
Comment 7 Timur 2021-03-19 15:36:48 UTC
*** Bug 104603 has been marked as a duplicate of this bug. ***
Comment 8 Xisco Faulí 2021-05-10 08:40:32 UTC
Rotation problem fixed by

https://cgit.freedesktop.org/libreoffice/core/commit/?id=3e4eb070787d4d44b3bdc95046e5b231dbbef42b

author  Xisco Fauli <xiscofauli@libreoffice.org>        2021-03-25 17:38:20
+0100
committer       Miklos Vajna <vmiklos@collabora.com>    2021-03-26 09:10:17
+0100
commit  3e4eb070787d4d44b3bdc95046e5b231dbbef42b (patch)
tree    185ec85a2454dcc8ac0428c38fa8b3f76d61d308
parent  1fcc08d5dccaf8280fa7709df6eb310b8f502fb2 (diff)
tdf#122717: fix handling of zero width/height lines

Closing as dupe of bug 122717

*** This bug has been marked as a duplicate of bug 122717 ***