Bug 104611 - Master slide drop down menu in Slide content panel exceeds Sidebar size when master slide name is long
Summary: Master slide drop down menu in Slide content panel exceeds Sidebar size when ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.2.4.1 rc
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-Properties-Slide
  Show dependency treegraph
 
Reported: 2016-12-12 17:10 UTC by sergio.callegari
Modified: 2017-06-08 11:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2016-12-12 17:10:24 UTC
Sidebar should be resizable. However, some of its elements do not rearrange well and in some cases when in "properties" mode the sidebar cannot be resized at all.

To reproduce:

open draw
select a master slide that has a very long name e.g. "Layout_foo_bar_baz_foobar_bar_bar_barfoo_foobar" (this may seem silly, but you can easily get things like this when importing presentations).
put the sidebar in slide-transition mode
resize the sidebar to be relatively slim
put the sidebar in properties mode
note that the buttons do not rearrange to fit the "slim" toolbar space (they are too large and they disappear to the right. The button text stays centered in the button and also partially disappears)
try to resize the sidebar. Note that the sidebar jumps to a much larger width and stays, cannot be resized anymore.
Comment 1 sergio.callegari 2016-12-12 17:11:33 UTC
Note: seen in 5.2.4.1 but probably introduced much earlier. Also seen in 5.3.0 beta 2.
Comment 2 Buovjaga 2016-12-14 14:01:53 UTC
It does not depend on the name of the master slide. This is kind of the root issue of bug 83526. There might be other reports.

Sergio: please evaluate and close your report as duplicate of either bug 83526 or some more appropriate one.
Comment 3 sergio.callegari 2016-12-14 14:18:30 UTC
I see the point with bug 83526. Yet, I think that the issue here is slightly different and simpler, because things go from being hardly usable (with a long name for the master slide) to getting ugly (because of 83526) but usable (renaming the master slide to a shorter name).

The problem here is that the text box containing the master slide name automatically adjusts to a length that is max(some minimal length, length of the master slide name), which can be way too long. The text box should be prevented from growing to a too big length. Conversely, the text in it should be either made scrollable with the cursor or shown compressed to some length e.g. ("very_long_master_slide_name" -> "very_long_m...")
Comment 4 Buovjaga 2016-12-14 20:00:30 UTC
Ok please give better steps on giving the long name. I tried it, but the name did not appear in the properties deck.
Comment 5 Linus 2017-06-07 11:54:21 UTC
I just ran into the same problem. The essential step in reproducing it is to reload or reopen the file where an overlong master slide name is used. I recorded this video: https://www.youtube.com/watch?v=Vkg9qI1fKQQ
Comment 6 Buovjaga 2017-06-07 13:42:35 UTC
NEW per comment 5
Comment 7 Yousuf Philips (jay) (retired) 2017-06-07 21:23:03 UTC
Cant repo in 5.3 or master. Please retest with a newer version and then provide the version info from Help > About LibreOffice.

Version: 5.3.3.2
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; VCL: gtk2; Layout Engine: new; 
Locale: en-US (en_US.UTF-8); Calc: group

Version: 5.5.0.0.alpha0+
Build ID: ddf8539d97ce044b7df8d51d6ec72ec864b40fb8
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-06-04_22:10:59
Locale: en-US (en_US.UTF-8); Calc: group
Comment 8 Linus 2017-06-08 09:06:03 UTC
Sorry, I only have the "stable" versions of LibreOffice installed. Tried it and can reproduce with both:


Version: 5.2.7.2 (x64)
Build ID: 2b7f1e640c46ceb28adf43ee075a6e8b8439ed10
CPU Threads: 8; OS Version: Windows 6.19; UI Render: default; 
Locale: de-DE (en_GB); Calc: group

and

Version: 5.2.5.1
Build ID: 1:5.2.5~rc1-0ubuntu1~trusty0
CPU Threads: 8; OS Version: Linux 3.13; UI Render: GL; VCL: gtk2;
Locale: en-GB (en_GB.UTF-8); Calc: group
Comment 9 Buovjaga 2017-06-08 09:11:20 UTC
Linus: an easy way to try on Win is to install a dev version, which will not mess up your stable one: http://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/current/
Comment 10 Linus 2017-06-08 09:36:50 UTC
Thanks for the hint. Just tried it with

Version: 5.5.0.0.alpha0+ (x64)
Build ID: 4ec3a5e7c2f63136cb48356d8d44703bfe0e3d9e
CPU threads: 8; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-06-08_05:29:50
Locale: en-GB (en_GB); Calc: CL

The issue seems to be resolved there!
Comment 11 Buovjaga 2017-06-08 10:16:13 UTC
That's frigging awesome. We could close a report for free!
Comment 12 Katarina Behrens (Inactive) 2017-06-08 11:05:21 UTC
It is this particular commit: https://cgit.freedesktop.org/libreoffice/core/commit/?id=ea1b27b3b579fd2896c5e054422e909c6739ad86 

that fixes the issue so the appropriate resolutions is likely RESOLVED FIXED for 5.4 and afaics it's also been backported to 5.3.x (but I don't know the value of 'x')