Download it now!
Bug 104625 - Even lines are displayed on the right side, Enter a line break in odd lines (Vertical Writing and Text Grid)
Summary: Even lines are displayed on the right side, Enter a line break in odd lines (...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.beta2
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CJK Vertical-Text
  Show dependency treegraph
 
Reported: 2016-12-13 08:56 UTC by nogajun
Modified: 2017-02-27 03:42 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Even lines are displayed on the right side. (11.79 KB, application/vnd.oasis.opendocument.text)
2016-12-13 09:07 UTC, nogajun
Details
Illustration (34.30 KB, image/png)
2016-12-17 08:00 UTC, Mark Hung
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nogajun 2016-12-13 08:56:51 UTC
Description:
Using vertical writing and text grid.
Enter a line break in odd lines, then even lines are displayed on the right side.

Steps to Reproduce:
1. Set Locale Options (Tool->Options)

Language Settings
- Default Languages for Documents: Check "Asian" and "Japanese"

2. Set vertical writing and grid text for page style

Menu: Format -> Page...

[Page]
- Orientation: Landscape
- Text direction: Right-to-left(vertical)

[Text Grid]
- Grid: Check "Grid(lines and characters)"
- Grid Layout:
    - Lines per page: 20
    - Characters per line: 20

3. Press the Enter key on odd lines(first line) then moves to the right side. 


Actual Results:  
Press the Enter key on odd lines move the cursor to the right side. and Press the Enter key again to return to the left.
Enabling the line number(tools->Line numbering...), Displayed as 1,3,5...


Expected Results:
Lines are displayed from the right to left side. not jumping right-left-right.
Line numbers are displayed 1, 2, 3, 4... from the right to left.



Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 nogajun 2016-12-13 09:07:16 UTC
Created attachment 129565 [details]
Even lines are displayed on the right side.
Comment 2 nogajun 2016-12-13 09:12:06 UTC
Environment:

Version: 5.3.0.0.beta2
Build ID: a7e30712ad6d8bc9286007b37aa581983e0caba3
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; Layout Engine: new; 
Locale: en-US (C); Calc: group


Version: 5.3.0.0.beta2
Build ID: a7e30712ad6d8bc9286007b37aa581983e0caba3
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
Locale: ja-JP (ja_JP); Calc: group
Comment 3 Mark Hung 2016-12-17 07:24:30 UTC
Confirmed

Version: 5.3.0.0.beta2
Build ID: a7e30712ad6d8bc9286007b37aa581983e0caba3
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
Locale: en-US (zh_TW); Calc: single
Comment 4 Mark Hung 2016-12-17 08:00:29 UTC
Created attachment 129706 [details]
Illustration

Place cursor after first character, press enter. Characters after the first one disappears.
Comment 5 Mark Hung 2017-02-27 03:42:18 UTC
I can't reproduce it in 5.3.0.3. This might related to my commit 611354a1c2e8281a80a1c3f5076a6c4593a4fe10, so I set this to WORKSFORME.


版本:5.3.0.3
組建 ID:7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU 執行緒:8; OS 版本:Windows 6.2; UI 算繪:預設; 介面配置引擎:新式; 
語言地區:zh-TW (zh_TW); Calc: single